Bug 186444 - Switch user problem with default screen saver (Floating Fedora Bubbles)
Switch user problem with default screen saver (Floating Fedora Bubbles)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks: FC5Update
  Show dependency treegraph
 
Reported: 2006-03-23 11:48 EST by Otto Rey
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: gnome-screensaver-2.18.2-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 00:52:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch for fedoralogo-floaters-lock-dialog.tar.gz files (20.27 KB, patch)
2006-08-29 04:14 EDT, Eric Lassauge
no flags Details | Diff
Patch to gnome-screensaver.spec (5.57 KB, patch)
2006-08-29 04:15 EDT, Eric Lassauge
no flags Details | Diff
Screendump of working dialog AFTER patches... SORRY this was the wrong file !!! Another one will be attached (37.54 KB, image/png)
2006-08-29 04:16 EDT, Eric Lassauge
no flags Details
gnome-screensaver-fedoralogo-floaters-lock-dialog REAL screendump (38.07 KB, image/png)
2006-08-30 11:52 EDT, Eric Lassauge
no flags Details

  None (edit)
Description Otto Rey 2006-03-23 11:48:12 EST
Description of problem:
When activate screensaver switch user buton in gconf, the default screen saver
not show the unlock dialog

Version-Release number of selected component (if applicable): gnome 2.14 - FC5


How reproducible:
Ever

Steps to Reproduce:
1. Run gconf-editor. Navigate to apps/gnome-screensaver. Turn on the flag
user_switch_enable.
2. Go to Preferences -> Screensaver and choose Floating Fedora Bubbles.
3. Lock the screen. Move the mouse or press a key and the unlock dialog does not
come visible.
  
Actual results:
The unlock dialog is not showed. Can't unlock the workstation.

Expected results:
Show unlock dialog with switch user buton (Like the other screensavers)

Additional info:
This is related with the bug 186440 because the problem is with the unlock
dialog that have fedora look and feel. A "normal" unlock dialog is viewed
correctly with the buton.
Comment 1 mokkarkay 2006-03-26 03:27:13 EST
I confirm this bug exist.
Comment 2 Aaron Gaudio 2006-05-01 09:25:10 EDT
This may be related to
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=190339, which is caused by
a  dependence on /etc/X11/gdm/gdm.conf, which no longer exists. I wrote that up
separately since it has more details on the cause of the problem.
Comment 3 Pedro Lamarão 2006-06-07 09:31:52 EDT
This doesn't happen with an up to date Fedora Core 5 system.
Comment 4 Otto Rey 2006-06-07 09:50:23 EDT
Yes, this apparently was fixed with last Update (06/06) but Fedora look and feel
in unlock window is missing (Related to bug 186440)
Comment 5 Otto Rey 2006-06-07 10:28:07 EDT
NO, this is NOT fixed (worse than before): sometimes Floating Fedora Bubbles
show unlock dialog without Look And Feel (like the others screen savers), and is
working well (unlock dialog comes with switch user button). But randomly, it
show unlock dialog with Look and Feel (like before updates) and the problem
persist (no unlock dialog).
Comment 6 Pedro Lamarão 2006-06-07 10:49:49 EDT
It is not "worse than before".
Before it did not work. Now it works.
This bug should be marked as closed and a new bug about look-and-feel
inconsistencies opened.
Comment 7 Otto Rey 2006-06-07 10:54:04 EDT
You dont understand: this is NOT WORKING. Before updates, this is not working
and now is randomly not working (worse than before.. random isn't a good symptom)
Comment 8 Otto Rey 2006-06-07 11:02:42 EDT
Before Update:

- Floating Fedora Bubbles show Unlock dialog with look and feel. With switch
user is enabled, never show unlock dialog.

After Update:

- Floating Fedora Bubbles show Unlock dialog sometimes with look and feel,
sometimes no. When switch user is enabled and Floating Fedora Bubbles try to
display unlock dialog with look and feel (random), fail like before update.

Comment 9 Eric Lassauge 2006-08-29 04:14:18 EDT
Created attachment 135109 [details]
Patch for fedoralogo-floaters-lock-dialog.tar.gz files
Comment 10 Eric Lassauge 2006-08-29 04:15:45 EDT
Created attachment 135110 [details]
Patch to gnome-screensaver.spec
Comment 11 Eric Lassauge 2006-08-29 04:16:55 EDT
Created attachment 135111 [details]
Screendump of working dialog AFTER patches...
SORRY this was the wrong file !!! Another one will be attached
Comment 12 Eric Lassauge 2006-08-29 04:23:32 EDT
Sorry I made a mistake with my first initial comment (should have been before
the attached files !).

I recently tried to switch to gnome-screensaver-2.15.7 and I confirm the initial
bug: there are errors in gnome-screensaver that prevents the
fedoralogo-floaters-lock-dialog to work: see
http://bugzilla.gnome.org/show_bug.cgi?id=352812.
I attached in the previous comments the patches that I made (for information only):
- some of the files moved (maybe due to new gnome-screensaver-2.15.7)
- fedoralogo-floaters-lock-dialog needs to be corrected (see Comment #9) to work
- the spec file was changed to accomodate the new gnome-screensaver-2.15.7.
Hope this helps
Comment 13 Ray Strode [halfline] 2006-08-29 10:14:27 EDT
Thanks for the help, Eric.
Comment 14 Eric Lassauge 2006-08-30 11:50:03 EDT
Comment on attachment 135111 [details]
Screendump of working dialog AFTER patches...
SORRY this was the wrong file !!! Another one will be attached 

><HTML><BODY>
<H1>Sorry this is a wrong file</H1>
<IMG src="https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=135111"
alt="https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=135111"/></BODY></H
TML>
Comment 15 Eric Lassauge 2006-08-30 11:52:29 EDT
Created attachment 135222 [details]
gnome-screensaver-fedoralogo-floaters-lock-dialog REAL screendump

This is now the correct screen	dump - Sorry

Note You need to log in before you can comment on or make changes to this bug.