Bug 186490 - segmentation fault when using dos2unix
segmentation fault when using dos2unix
Status: CLOSED DUPLICATE of bug 150277
Product: Fedora
Classification: Fedora
Component: dos2unix (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
: 186491 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-23 15:46 EST by Daniel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-23 18:10:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch missing a "+1" in : fname_len = strlen(dir) + strlen("/d2utmpXXXXXX") + 1; (646 bytes, patch)
2006-03-23 15:46 EST, Daniel
no flags Details | Diff

  None (edit)
Description Daniel 2006-03-23 15:46:07 EST
Description of problem:
When passing a particular length of path to dos2unix we get a segmentation 
fault.

Version-Release number of selected component (if applicable):
3.1

How reproducible:
In certain cases...I reproduce it with a pathname of length=63 without the 
trailing '/'

Steps to Reproduce:
1.
2.
3.
  
Actual results:
dos2unix: converting 
file /home/danielc/1234567891123456789212345678931234567894123456789/bob.tmp 
to UNIX format ...
fname_len=76     (path + /d2utmpXXXXXX)
Segmentation fault

Expected results:
no segmentation fault :)

Additional info: see patch
Comment 1 Daniel 2006-03-23 15:46:07 EST
Created attachment 126572 [details]
Patch missing a "+1" in :   fname_len = strlen(dir) + strlen("/d2utmpXXXXXX") + 1;
Comment 2 Miloslav Trmač 2006-03-23 18:05:51 EST
*** Bug 186491 has been marked as a duplicate of this bug. ***
Comment 3 Tim Waugh 2006-03-23 18:10:21 EST

*** This bug has been marked as a duplicate of 150277 ***

Note You need to log in before you can comment on or make changes to this bug.