Bug 18652 - Installer crashes during Custom Setup
Installer crashes during Custom Setup
Status: CLOSED DUPLICATE of bug 18031
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-08 15:16 EDT by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-09 19:39:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda dump file. (1.74 KB, text/plain)
2000-10-08 15:17 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2000-10-08 15:16:34 EDT
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in 
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in 
setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/package_gui.py", line 
427, in getScreen
    self.todo.getCompsList()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in 
getCompsList
    self.comps = self.method.readComps(self.hdList)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 16, in 
readComps
    return ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in 
__init__
    self.readCompsFile(file, self.packages, arch, matchAllLang)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in 
readCompsFile
    comp.addPackage(packages[l])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in 
__getitem__
    return self.packages[item]
KeyError: chkconfig

Local variables in innermost frame:
self: <comps.HeaderListFromFile instance at 84eb058>
item: chkconfig

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Need Real Name 2000-10-08 15:17:58 EDT
Created attachment 3867 [details]
Anaconda dump file.
Comment 2 Michael Fulbright 2000-10-09 10:51:39 EDT
This is almost certainly due to either a bad CD image or a problem with a CDROM
drive.

Does this happen to be a CD you burned yourself?
Comment 3 Need Real Name 2000-10-09 19:39:21 EDT
Yes, this is from a CD I burned myself.  I used Adaptecs Easy CD Creator 
version 3.5c to burn the ISO images.  Before burning the CD I ran the checksum 
against both ISO images and they matched up perfectly.  I downloaded the ISO 
files from ftp.freesoftware.com.

My system setup:
PIII 500MHz
256 MB RAM
Western Digital 20.5 GB hard drive
Matshita LS-120 floppy drive
LITEON CD-ROM LTN382 (This is the boot CD-ROM)
Yamaha CRW8424E CD-ROM
U.S. Robotics 56k Voice Winmodem
U.S. Robotics 56k Fax/Data external modem
ATI Rage 128 Magnum SD AGP video card
Creative Labs Sound Blaster Live Value sound card
Hewlett Packard DeskJet 810C printer

The hard drive was a virgin install.  I bought the drive so Red Hat could have 
its own hdd.

Would you suggest making the Yamaha CD-RW drive the boot drive?  Or do you 
suggest downloading the images files again from a different source?
Comment 4 Michael Fulbright 2000-10-27 15:35:41 EDT
I would suggest trying to get the ISO's from ftp.redhat.com and reburning them.

There are lots of people who have seen this problem, all at different packages.
All of them seem to have burned their own CDs.



*** This bug has been marked as a duplicate of 18031 ***

Note You need to log in before you can comment on or make changes to this bug.