Bug 1865998 - Test Failure: displays Operator as subscribed in OperatorHub
Summary: Test Failure: displays Operator as subscribed in OperatorHub
Keywords:
Status: CLOSED DUPLICATE of bug 1866296
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.6.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-04 15:53 UTC by Samuel Padgett
Modified: 2020-08-18 17:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-18 17:16:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6225 0 None closed Bug 1865998: Tolerate multiple package manifests with the same name 2020-08-17 06:47:25 UTC

Comment 1 Samuel Padgett 2020-08-04 17:38:48 UTC
Queue appears to be broken, raising severity.

Comment 2 Samuel Padgett 2020-08-05 16:06:12 UTC
Updating the title since this appears to be a real bug (and a symptom of bug 1814822).

Comment 5 XiaochuanWang 2020-08-12 09:24:55 UTC
I saw there is still some similar failed logs in https://search.ci.openshift.org/?search=%E2%9C%96+displays+Operator+as+subscribed+in+OperatorHub+&maxAge=48h&context=1&type=build-log&name=&maxMatches=5&maxBytes=20971520&groupBy=job
Such as https://prow.ci.openshift.org/view/gs/origin-ci-test/pr-logs/pull/openshift_console/6272/pull-ci-openshift-console-master-e2e-gcp-console/1293295839287971840
Log is raised at 2020-08-11 21:18:53 +0000 UTC

Failed Specs:
1) Interacting with an `AllNamespaces` install mode Operator (Jaeger) : displays Operator as subscribed in OperatorHub
   TimeoutError: Wait timed out after 20000ms
       at /go/src/github.com/openshift/console/frontend/node_modules/selenium-webdriver/lib/promise.js:2201:17
       at ManagedPromise.invokeCallback_ /go/src/github.com/openshift/console/frontend/node_modules/selenium-webdriver/lib/promise.js:1376:14
       at TaskQueue.execute_ /go/src/github.com/openshift/console/frontend/node_modules/selenium-webdriver/lib/promise.js:3084:14
       at TaskQueue.executeNext_ /go/src/github.com/openshift/console/frontend/node_modules/selenium-webdriver/lib/promise.js:3067:27
       at asyncRun /go/src/github.com/openshift/console/frontend/node_modules/selenium-webdriver/lib/promise.js:2927:27
skipped 77 lines unfold_more
2020/08/11 22:22:20 Container test in pod e2e-gcp-console failed, exit code 1, reason Error
2020/08/11 22:35:27 Copied 159.34MB of artifacts from e2e-gcp-console to /logs/artifacts/e2e-gcp-console
2020/08/11 22:35:27 Releasing lease for "gcp-quota-slice"
2020/08/11 22:35:27 No custom metadata found and prow metadata already exists. Not updating the metadata.
2020/08/11 22:35:27 Ran for 1h16m2s
error: some steps failed:
  * could not run steps: step e2e-gcp-console failed: template pod "e2e-gcp-console" failed: the pod ci-op-krsdrhcx/e2e-gcp-console failed after 1h6m49s (failed containers: test): ContainerFailed one or more containers exited
Container test exited with code 1, reason Error

Could you help to have a check?

Comment 6 Samuel Padgett 2020-08-18 17:16:16 UTC
We fixed one issue, but there are still some other flakes being tracked under bug 1866296. I'm going to duplicate this one to that bug.

*** This bug has been marked as a duplicate of bug 1866296 ***


Note You need to log in before you can comment on or make changes to this bug.