Bug 1866296 - pull-ci-openshift-console-master-e2e-gcp-console consistently broken
Summary: pull-ci-openshift-console-master-e2e-gcp-console consistently broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: David Taylor
QA Contact: Yanping Zhang
URL:
Whiteboard:
: 1865998 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-05 10:35 UTC by Alberto
Modified: 2020-10-27 16:25 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:24:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6330 0 None closed Bug 1866296: wait for Jaeger tile before trying to click 2020-09-07 01:59:41 UTC
Github openshift console pull 6360 0 None closed Bug 1866296: Disable e2e OLM test flakes 2020-09-07 01:59:41 UTC
Github openshift console pull 6372 0 None closed Bug 1866296: Cypress CRUD tests flake fixes 2020-09-07 01:59:42 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:25:10 UTC

Description Alberto 2020-08-05 10:35:30 UTC
Description of problem:


https://prow.ci.openshift.org/job-history/origin-ci-test/pr-logs/directory/pull-ci-openshift-console-master-e2e-gcp-console is consistently broken.

Latests build shows different errors:
displays subscription creation form for selected Operator
displays Operator as subscribed in OperatorHub
displays subscription creation form for selected Operator

Comment 1 David Taylor 2020-08-13 13:04:49 UTC
Sam Padgett wrote: "There’s a confluence of things. The olm custom catalog isn’t loading before the tests run.  We updated the olm tests around the same time we added cypress. Then I suspect an auth change might have affected us yesterday [8/12]"

irt. the Cypress test failures, PR (https://github.com/openshift/console/pull/6319) was put in on 8/12 which seemed to fix the cypress flakes

There does seem to be olm flake when the catalog does load:

"[SEVERE] https://console-openshift-console.apps.ci-op-gnx2w8cv-75d12.origin-ci-int-gce.dev.openshift.com/static/main-chunk-737049ed273daaf189aa.min.js 0:1219704 "Uncaught error" "Uncaught TypeError: Cannot read property 'style' of null"

Investigating....

Comment 2 David Taylor 2020-08-13 15:52:46 UTC
The full olm error I saw was:

2) Interacting with an `AllNamespaces` install mode Operator (Jaeger) : displays subscription creation form for selected Operator
   Error: Failed: omg js error: Uncaught TypeError: Cannot read property 'style' of null


Just ran it twice locally and works, so seems to be a flake caused by catalog not loading:

2) Interacting with an `AllNamespaces` install mode Operator (Jaeger)
   ✔ displays subscription creation form for selected Operator
   ✔ selects all namespaces for Operator subscription
   ...

So does seem to be a true flake, most likely caused by olm custom catalog not initially loading -not an error in the test.

Comment 3 Samuel Padgett 2020-08-13 17:24:18 UTC
https://github.com/openshift/console/pull/6327 updates the junit report filename so it gets indexed by ci-search, which will help us understand how often each flake is occurring.

Comment 4 David Taylor 2020-08-13 17:25:48 UTC
PR was merged a couple of days ago [8/9] which was hoped to improve OLM scenario reliability.  It looks like the olm catalog is loading but the tests aren't waiting long enough:
https://github.com/openshift/console/pull/6253

Comment 5 Samuel Padgett 2020-08-13 20:39:09 UTC
I believe the linked PR will fix the 3 errors mentioned in the description. If we see other problems, we should track under separate Bugzilla bugs.

Comment 6 Samuel Padgett 2020-08-18 17:16:16 UTC
*** Bug 1865998 has been marked as a duplicate of this bug. ***

Comment 9 XiaochuanWang 2020-09-07 02:00:07 UTC
Checked the recent logs, there is no such flake as describe or anything related to olm operators/subscriptions which broke the integration testing.
This could be Verified.

Comment 11 errata-xmlrpc 2020-10-27 16:24:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.