Bug 1866347 - Wrong format for monitoring keepalived
Summary: Wrong format for monitoring keepalived
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
urgent
medium
Target Milestone: ---
: 4.6.0
Assignee: Yuval Goldberg
QA Contact: Constantin Vultur
URL:
Whiteboard: OCP-Metal-External-Blocker
: 1866348 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-05 11:55 UTC by Yuval Goldberg
Modified: 2020-10-27 16:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:24:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift baremetal-runtimecfg pull 89 0 None closed Bug 1866347: monitoring keepalive wrong format 2020-10-07 13:16:20 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:25:10 UTC

Description Yuval Goldberg 2020-08-05 11:55:04 UTC
Description of problem:

Deploying multiple assisted installers where the user does not provide the VIP addresses with the same cluster name ends up with them competing for the same DHCP leased address and conflicting.

Version:
baremetal-runtimecfg 4.6

Steps to reproduce:
1. Deploy an assisted installer cluster without providing VIPs specifying clustername='reproducer'
2. Deploy another cluster on the same DHCP served network without providing VIP addresses and specifying the same clustername, i.e., 'reproducer'

Actual results:
Both the first and the second cluster ask DHCP for a lease with the same MAC address, thus the first cluster breaks as the address is taken by the second and the second fails to deploy.

Expected results:
Each cluster requests different addresses to DHCP so we keep allowing multiple clusters named the same

Comment 1 Andrea Fasano 2020-08-11 16:06:40 UTC
Yuval could you please provide more details about the problem? The description is not very clear. Thanks

Comment 4 Ronnie Lazar 2020-08-26 12:02:06 UTC
*** Bug 1866348 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2020-10-27 16:24:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.