Bug 1866348 - Wrong format for monitoring keepalived
Summary: Wrong format for monitoring keepalived
Keywords:
Status: CLOSED DUPLICATE of bug 1866347
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 4.6.0
Assignee: Yuval Goldberg
QA Contact: Amit Ugol
URL:
Whiteboard: OCP-Metal-External-Blocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-05 11:55 UTC by Yuval Goldberg
Modified: 2020-08-26 12:02 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-08-26 12:02:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yuval Goldberg 2020-08-05 11:55:22 UTC
Description of problem:

Deploying multiple assisted installers where the user does not provide the VIP addresses with the same cluster name ends up with them competing for the same DHCP leased address and conflicting.

Version:
baremetal-runtimecfg 4.6

How reproducible:

Steps to Reproduce:
1. Deploy an assisted installer cluster without providing VIPs specifying clustername='reproducer'
2. Deploy another cluster on the same DHCP served network without providing VIP addresses and specifying the same clustername, i.e., 'reproducer'

Actual results:
Both the first and the second cluster ask DHCP for a lease with the same MAC address, thus the first cluster breaks as the address is taken by the second and the second fails to deploy.

Expected results:
Each cluster requests different addresses to DHCP so we keep allowing multiple clusters named the same

Comment 2 Ronnie Lazar 2020-08-26 12:02:06 UTC

*** This bug has been marked as a duplicate of bug 1866347 ***


Note You need to log in before you can comment on or make changes to this bug.