Bug 186662 - Spacing for capital "T" and some other letters is garbled
Spacing for capital "T" and some other letters is garbled
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
: 186718 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-25 00:23 EST by Paul W. Frields
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-27 17:56:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 334758 None None None Never

  None (edit)
Description Paul W. Frields 2006-03-25 00:23:42 EST
Description of problem:
Some spacing is off.  Capital "T" allows the next lowercase letter to be too
close using the "Normal" (i.e. non-bold, non-oblique) face.  I'm sorry I don't
know the technical terms for this anomaly.

Version-Release number of selected component (if applicable):
2.4-1.fc5

How reproducible:
Every time

Steps to Reproduce:
1. Set fonts to 10.5 or 11 points, for example
2. Look at words like "Tomboy" or "DejaVu".

  
Actual results:
Some capital letters are spaced strangely.  This seems like a regression from
the previous version since I just updated tonight and don't remember it
happening previously.

Expected results:
Nicely spaced letters

Additional info:
Comment 1 Nicolas Mailhot 2006-03-25 04:42:36 EST
See also:

http://bugzilla.gnome.org/show_bug.cgi?id=334758
http://sourceforge.net/mailarchive/message.php?msg_id=15185495
https://launchpad.net/distros/ubuntu/+source/ttf-dejavu/+bug/35470/

So this is an upstream bug. Not clear right now if the bug in in DejaVu, Pango
or fontforge

I'm going to sit on it some time while the situtation clarifies. I urge you to
do the tests proposed in the Gnome bug and report your results there so the
clarification goes faster.

I'd rather not do a rollback before we know what needs to be fixed for the next
dejavu release
Comment 2 Paul W. Frields 2006-03-25 07:01:28 EST
Nicolas, it seems clear, especially from the last one you list:

  https://launchpad.net/distros/ubuntu/+source/ttf-dejavu/+bug/35470/

...that this is a Pango problem.  I installed freetype-demos-2.1.10-5.2.1, and ran:

  ftstring -m 'Terminal' 24 /usr/share/fonts/dejavu-fonts/DejaVuSans.ttf

Without using Pango, there's no kerning issue, results are similar enough to the
upstream bugs that there's no reason to upload additional screenshots here.  I'm
reassigning this bug to pango where it belongs.  Thanks for your help.
Comment 3 Kevin DeKorte 2006-03-25 12:11:07 EST
*** Bug 186718 has been marked as a duplicate of this bug. ***
Comment 4 Nicolas Mailhot 2006-03-29 12:33:57 EST
Since people in gnome bug seem to agree the short-term fix is to remove arabic
from dejavu (done in 2.4.1) and the long-term fix is to add opentype BASE table
support to FOSS font tools, I suggest to close this bug as upstream
Comment 5 Matthias Clasen 2006-06-20 01:11:48 EDT
Reassigning pango bugs to Behdad.
Comment 6 Behdad Esfahbod 2006-07-27 17:56:38 EDT
This is being tracked upstream, and dejavu has been fixed to not hit this bug in
the meanwhile.

Note You need to log in before you can comment on or make changes to this bug.