Bug 186708 - FC5 kernel lockups, call trace, network hangups
FC5 kernel lockups, call trace, network hangups
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
MassClosed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-25 10:29 EST by Bernd Bartmann
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-19 23:37:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of call trace during boot process (3.08 MB, image/jpeg)
2006-03-25 10:32 EST, Bernd Bartmann
no flags Details
screenshot a hanging boot process (2.68 MB, image/jpeg)
2006-03-25 10:33 EST, Bernd Bartmann
no flags Details
/var/log/messages showing kernel call trace (95.01 KB, text/plain)
2006-03-25 10:34 EST, Bernd Bartmann
no flags Details

  None (edit)
Description Bernd Bartmann 2006-03-25 10:29:27 EST
Description of problem:
I having massive problems with the default FC5 i686 kernel. I tried to install
FC5 using a PXE network install. The network card is detected (tg3 driver) the
systems gets an IP address via DHCP. After entering the NFS server name and path
to the DVD image my whole network is being blocked after some time, i.e. no
other system can communicate with the NFS server anymore. The NFS server is
RHES4U3. After switching off the FC5 install client the network becomes usable agin.

As network install is impossible I decided to install FC5 locally from the DVD.
When I booted the system after the install process I saw a call trace (see
screenshot #1) the boot process continued but then hung completely (see
screenshot #2).

After rebooting the system came up completely but my network was blocked again
after some network activity.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. have some network activity on a tg3 network card
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bernd Bartmann 2006-03-25 10:32:23 EST
Created attachment 126724 [details]
screenshot of call trace during boot process
Comment 2 Bernd Bartmann 2006-03-25 10:33:55 EST
Created attachment 126725 [details]
screenshot a hanging boot process
Comment 3 Bernd Bartmann 2006-03-25 10:34:53 EST
Created attachment 126726 [details]
/var/log/messages showing kernel call trace
Comment 4 Bernd Bartmann 2006-03-31 13:35:53 EST
Problem still persists with kernel-2.6.16-1.2080_FC5.
Comment 5 Dave Jones 2006-10-16 13:31:49 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 6 Bernd Bartmann 2007-01-28 09:56:07 EST
Still the same problems here with the current FC6 kernel. In the meantime I
found out that my system is stable when I pass "noapic acpi=off" to the kernel
command line.
Comment 7 Jon Stanley 2008-01-19 23:37:22 EST
(this is a mass-close to kernel bugs in NEEDINFO state)

As indicated previously there has been no update on the progress of this bug
therefore I am closing it as INSUFFICIENT_DATA. Please re-open if the issue
still occurs for you and I will try to assist in its resolution. Thank you for
taking the time to report the initial bug.

If you believe that this bug was closed in error, please feel free to reopen
this bug.

Note You need to log in before you can comment on or make changes to this bug.