Bug 18676 - Autorun, Auto mount or Cd_ROM errors!!!
Autorun, Auto mount or Cd_ROM errors!!!
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: cdp (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Crutcher Dunnavant
Dale Lovelace
:
: 18677 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-09 02:40 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-19 14:05:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-09 02:40:47 EDT
Hi 

I have two systems the one I recently upgraded from rh6.2 to rh7 and know 
I can't read some CD-ROMs on the system. This was not the case with rh6.2 
or rh6.1 I take it that this is a bug with your new enhancement that you 
don't have to unmount the CDROM to remove it (which by the way is a pretty 
nice enhancement.)
And what makes me sure it is a bug is the fact that I made a fresh 
installation on my other system a IBM 300PL and I have the same problems.

The errors include:
Not showing al the files on the CD-ROM.
Not displaying the names of the files or directories on the CD-ROM.
Not being able to mount the CD-ROM error bad supperblok.

What is strange is that on my first system I have a HP9300 CD writer on 
the secondary IDE as master and a LG 48X8 DVD_ROM on the same IDE Channel 
as slave, and I only have this problem on the HP9300.

PS. I was using a GNOME desktop so it could be that but I doubt it.

Thanks
Frederik
Comment 1 Crutcher Dunnavant 2000-10-11 11:55:30 EDT
Just a suggestion, unlikely to be a fix:
The autofs mounts have timeouts associated with them,
and it affects howlong the system takes to unmount a
device (like the cdrom). Only after it has unmounted the
old one, will it mount a new one (even if it has been swaped)

You can look at this in the /etc/auto.mnt file, but I'm not sure if it is
the cause.

The cds in question might use the joliette extension, and I'll have to ask the
kernel guys if the kernel shiped with 7 reads that. Or, the cds might be
getting marginal, and one drive is better at reading them.

--
Can you find any pattern in the CD-ROMs that it wont read?
Comment 2 Crutcher Dunnavant 2000-10-11 11:55:51 EDT
*** Bug 18677 has been marked as a duplicate of this bug. ***
Comment 3 Need Real Name 2000-10-19 05:23:03 EDT
I have some of the same CD-problems with my RH-7.0 systems, and would like to
add a comment.
I have two systems which I upgraded from 6.2 to 7.0. After the upgrade I was no
longer able to mount CD-rom's, got the errormsg:

 mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
       or too many mounted file systems
       (aren't you trying to mount an extended partition,
       instead of some logical partition inside?)

No atomount worked.

Then I realised that if I created a new user, this user had no problems.
Automount allso worked fine for users created after the upgrade to 7.0.

Now I have two systems where old (pre 7.0 created) users, including root, are
unable to use CD's, but where the newly created users have no problems.

In his comment, crutcher mentioned a file called /etc/auto.mnt. I am not able to
locate this file on any of my two systems.

-akt-
Comment 4 Crutcher Dunnavant 2000-10-19 11:32:16 EDT
Couple of questions:

Are you running autofs?
If so, please post copies of every /etc/auto.*

Do you have a line similar to this in your fstab?
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,ro 0 0

Comment 5 Need Real Name 2000-10-19 14:05:29 EDT
Hi

I don't no, will need to reboot to RH7. But I did found what was causing the 
problem: If I press the physical open/close button when a Cd was mounted and 
inserted another Cd, I could not read all of it's contents, but if I right 
clicked on the CDROM icon and eject the Cd from the desktop and then reinserted 
the Cd I could read it fine. So for now I'm staying clear of the open/close 
button. Try it on your system and let me know if you can duplicate the error.

PS. With previous versions of RH I could not open the CDROM without unmounting 
it first.

Hope this helps

Cheers
Kammies
Comment 6 Crutcher Dunnavant 2001-03-14 12:45:01 EST
sounds like this was an file manager interaction, and not a cdplay problem

Note You need to log in before you can comment on or make changes to this bug.