Bug 186766 - My Epson Perfection 2450 Photo scanner won't work with USB 2.0
My Epson Perfection 2450 Photo scanner won't work with USB 2.0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-26 04:12 EST by David Fletcher
Modified: 2008-10-20 20:49 EDT (History)
7 users (show)

See Also:
Fixed In Version: 1.0.18-7.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-05 15:17:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from "lsusb -v" with USB 2.0 disabled (17.58 KB, text/plain)
2006-03-28 14:46 EST, David Fletcher
no flags Details
output from "lsusb -v" with USB 2.0 enabled (19.67 KB, text/plain)
2006-03-28 14:51 EST, David Fletcher
no flags Details
Sane debug output showing "Error during device I/O message" (10.91 KB, text/plain)
2006-10-16 20:33 EDT, Michael Fischer
no flags Details
Sane debug output showing "Error during device I/O message" (11.92 KB, text/plain)
2006-10-16 23:30 EDT, Michael Fischer
no flags Details

  None (edit)
Description David Fletcher 2006-03-26 04:12:56 EST
Description of problem: My Epson scanner (Perfection 2450 Photo) does not
operate with USB 2


Version-Release number of selected component (if applicable):


How reproducible: Try to use the scanner with xsane


Steps to Reproduce:
1. Log out (scanner won't work at all if connected whilst logged in - another
bug I believe)
2. Connect the scanner to a USB 2 socket
3. Log in
4. Start xsane
5. Try to get a preview
  
Actual results:
xsane gives the error "Failed to start scanner:- Error during device I/O"

Expected results:

Additional info:
I was contributing to bug number 149027 but now that I have more information
that one seems to be not applicable to me.

I have accused libusb of being at fault because:-

I think this bug is several months old. I still have FC3 running on the machine
I'm using now. Several months ago there was an FC3 update that included libusb.
At that time my scanner stopped working. I managed to make it work by backdating
libusb and a couple of other things that depended on it such as xsane.

There is another machine in the house that has an identical motherboard and
processor - Intel D865PERL motherboard with 3GHz P4 - which now has FC5
installed. If I plug my scanner into this machine, I get the bug. BUT

******************************
***   most important bit   ***
******************************

if I reboot the machine, go into the BIOS settings, and disable USB 2 support
the scanner then works - so long as I connect to one of the motherboard USB
sockets AND connect the scanner BEFORE I log in. I used the transparency adaptor
to scan a 6x6cm colour slide

******************************
******************************
******************************

Further information - I purchased a USB 2.0 PCI expansion card yesterday with a
different chip on it. The motherboard has Intel chips, the USB board I purchased
has a Via chip. I did this because I suspected that it is the Intel chips that
are not properly supported. But when I connect the scanner to the expansion card
I get the same error from xsane. We connected a USB flash drive to the expansion
card, and copied a file from it to the hard drive so the card is working.

I've not got an old USB1.1 expansion card to plug in and try, if I did I would
give it a whirl. I might ask on the local Linux Users Group if anybody has such
a card I could try.
Comment 1 Jindrich Novy 2006-03-27 02:02:53 EST
Could you please attach here the output of "lsusb -v" command when your scanner
is on? (lsusb comes from the usbutils package) 

The latest working version of libusb would also help me to figure out where's a
possible problem.

Does the lsusb command detect your scanner when you connect it when you are
logged in?
Comment 2 David Fletcher 2006-03-28 14:46:51 EST
Created attachment 126922 [details]
output from "lsusb -v" with USB 2.0 disabled
Comment 3 David Fletcher 2006-03-28 14:51:16 EST
Created attachment 126923 [details]
output from "lsusb -v" with USB 2.0 enabled

To answer the question, Yes lsusb does detect the scanner when it is switched
on whilst logged in.
Comment 4 Mike Cohler 2006-04-01 11:23:08 EST
I don;t know if this is related but I have fc5 final running and an Epson CX3200
connected via usb.  sane-find-scanner works and scanimage -L gives:
device `epson:libusb:001:002' is a Epson CC-570L flatbed scanner

OK so it is found....  running the GIMP and trying to acquire it does nothing,
but running kooka (all under KDE) finds the scanner just fine !!!

I have scanned images with no problem at all but the GIMP does not see the
scanner and does not start when the acquire -> scan .. is attempted.

Mike
Comment 5 Mike Cohler 2006-04-01 11:31:37 EST
However I now found that by removing the firectory .sane in the user area and
trying again - it works fine !

Mike
Comment 6 Jindrich Novy 2006-04-01 12:50:01 EST
Unfortunatelly I found nothing broken in the lsusb -v outputs you have attached
here. So I think libusb is not at fault here. I suspect xsane or the EHCI kernel
module is a culprit here because it refuses to communicate with your scanner for
some reason via EHCI interface (USB 2.0), but UHCI works.

Have you tried workaround that Mike presented?
Comment 7 David Fletcher 2006-04-02 13:08:35 EDT
I tried deleting .sane but it doesn't work. Still getting the same error message
when asking xsane to do a preview.

What diagnostics would you like me to run next?
Comment 8 Jindrich Novy 2006-04-19 09:26:35 EDT
Ok, reassigning to kernel, maybe we'll find out there more.
Comment 9 David Jansen 2006-04-26 09:12:36 EDT
I was pointed to this bug when I posted a similar situation on fedora-list:

Since rebooting my FC4 system with the latest kernel (2.6.16-1.2096_FC4smp)
my scanner, a HP scanjet 5300C connected through usb, is not recognized
any more. When plugging it in I get:

usb 3-1: new full speed USB device using uhci_hcd and address 2
usb 3-1: configuration #1 chosen from 1 choice
usb 3-1: can't set config #1, error -71

and of course, this results in no device that sane can use. Rebooting
back in kernel kernel-2.6.15-1.1833 makes the device work again.

However, sane-find-scanner reports:
  found USB scanner (vendor=0x03f0, product=0x0701) at libusb:003:002
so the device is not completely missing. Only question is: what do I do
to make sane see it, or, what changed in the last couple of kernel
updates?
Comment 10 David Fletcher 2006-05-06 10:40:44 EDT
I've just tested this on my fully up to date system with the 2111 kernel. It
still won't work with USB2.0.
Comment 11 David Fletcher 2006-06-14 11:14:38 EDT
The other scanner bug (won't work unless switched on before logging in) seems to
have been fixed, at least for me.

Is there anything I can do to help with this one yet?
Comment 12 Michael Fischer 2006-06-19 15:24:55 EDT
My Epson 2450 scanner used to work under older Fedora versions, but it didn't
work under FC4 on my old Pentium machine, and it doesn't work under FC5 on my
new AMD x86_64 box.  The scanner is recognized.  scan-find-scanner reports:
found USB scanner (vendor=0x04b8 [EPSON], product=0x0112 [EPSON Scanner]) at
libusb:002:009
scanimage -L says:
device `epson:libusb:002:009' is a Epson GT-9700 flatbed scanner
But scanimage with no parameters reports
scanimage: sane_start: Error during device I/O

The scanner works fine using the commercial vuescan-8.3 package, showing that
the scanner and USB ports are both working.

I spent some time looking at this problem in the past.  The failure seems to
happen during the initialization phase of the scanner.  It used to be possible 
to get the scanner initialized by running scanimage -L, then xsane, quitting it,
and running xsane again.  (That workaround failed with the upgrade to FC4.) 
Once the scanner was initialized, it would work perfectly for repeated scans,
but if xsane was quit and restarted, then it failed again with the device I/O
errors.  I believe there is some USB communication mode that is used only during
the initialization of this scanner and that that is where the failure occurs. 
However, I'm no USB expert, and as I said, the scanner works just fine with vuescan.
Comment 13 Dave Jones 2006-10-16 15:04:30 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 14 David Fletcher 2006-10-16 17:38:41 EDT
I just tested it with USB2.0 again with the new kernel. It still won't work.

With USB2.0 disabled it's happily scanning as I type this.

What else can I do to provide diagnostics for this problem? Is it the kernel or
the scanner that's causing the problem?
Comment 15 Michael Fischer 2006-10-16 20:33:57 EDT
Created attachment 138642 [details]
Sane debug output showing "Error during device I/O message"

Scanner still does not work under kernel 2.6.17-1.2187_FC5 and
sane-backends-1.0.18-2.fc5.x86_64.  Same symptoms as before -- scanner is
recognized but fails with "Error during device I/O" during initialization.
Comment 16 Michael Fischer 2006-10-16 23:30:01 EDT
Created attachment 138649 [details]
Sane debug output showing "Error during device I/O message"

Sorry -- didn't realize I wasn't running the latest kernel.  I repeated the
experiment with kernel 2.6.18-1.2200.fc5 and attached sane debug output.  It
still fails with "Error during device I/O" during initialization.
Comment 17 David Fletcher 2007-06-15 05:00:31 EDT
Please see my comment on bug #149027, following the link, which I think will
lead to working scanners everywhere.

This bug has been hanging around for far too long. Everybody who is suffering
from it please try out my solution. If it works for others I think it should be
closed.
Comment 18 Nils Philippsen 2007-06-15 09:22:25 EDT
There's a patch in bug #149027 (to call usb_reset() befort usb_close()) that
might be a sufficient workaround for the problem we see here, I'll building a
package for updates-testing shortly. Let's see how this works out.
Comment 19 Fedora Update System 2007-06-16 09:21:23 EDT
sane-backends-1.0.18-7.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 20 Michael Fischer 2007-06-17 17:47:02 EDT
sane-backends-1.0.18-7.fc7.x86_64 fixes my problem.  My Epson Perfection 2450
Photo scanner works again!
Comment 21 Fedora Update System 2007-07-05 15:17:30 EDT
sane-backends-1.0.18-7.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Michael Fischer 2008-10-20 20:49:34 EDT
The patch from comment #18 above, posted in bug #149027, has disappeared from sane-backends-1.0.19-10.fc9.  I recently upgraded to Fedora 9 and my Epson Perfection 2450 Photo scanner stopped working with the same problem as before.  I rebuilt the rpm with the patch and the scanner again works.

Note You need to log in before you can comment on or make changes to this bug.