Bug 186781 - sendmail 8.12.11-4.24.1.legacy breaks SMTP AUTH
sendmail 8.12.11-4.24.1.legacy breaks SMTP AUTH
Status: CLOSED DUPLICATE of bug 186579
Product: Fedora Legacy
Classification: Retired
Component: sendmail (Show other bugs)
rhl9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-26 08:06 EST by Bishop Clark
Modified: 2007-04-18 13:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-26 08:10:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bishop Clark 2006-03-26 08:06:49 EST
Description of problem:
upgrade to sendmail 8.12.11-4.24.1.legacy causes smtpauth to no longer function.

Version-Release number of selected component (if applicable):
sendmail 8.12.11-4.24.1.legacy

How reproducible:
always

Steps to Reproduce:
1.  install sendmail-8.12.8-9.90
2.  follow instructions at (eg)
http://www.whoopis.com/howtos/sendmail-auth-howto.html
3.  upgrade sendmail and sendmail-cf to 8.12.11-4.24.1.legacy, regenerate CF
files, restart sendmail, and cry.
  
Actual results:
Authentication is always denied:
Mar 26 04:20:05 fishy sendmail[21800]: k2QCK1hY021800: AUTH failure (PLAIN):
authentication failure (-13) (null)
Mar 26 04:20:06 fishy sendmail[21800]: k2QCK1hY021800: AUTH failure (LOGIN):
authentication failure (-13)
(at log level 13)

Expected results:
stat=sent

Additional info:
Using mozilla(seamonkey) 1.0 to test.  Tests pass with older RPM, fail with new
RPM.  Tested TLS yes/no, Auth yes/no.  TLS works, auth definitely affected.
Comment 1 Bishop Clark 2006-03-26 08:10:52 EST
The problem has been traced to the /etc/pam.d/smtp PAM module:  with sendmail
8.12.11-4.24.1.legacy, the smtp pam.d module is being shipped at smtp.sendmail,
and never moved (symlinked?) as pam.d/smtp.

This is a dupe of bug 186579, left here as an artefact for others to find in
case they run into the same bug.

*** This bug has been marked as a duplicate of 186579 ***

Note You need to log in before you can comment on or make changes to this bug.