Bug 186579 - sendmail 8.12.11-4.24.1.legacy does not provide /usr/lib/sendmail
sendmail 8.12.11-4.24.1.legacy does not provide /usr/lib/sendmail
Status: CLOSED ERRATA
Product: Fedora Legacy
Classification: Retired
Component: sendmail (Show other bugs)
rhl9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
:
: 186781 186783 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-24 10:33 EST by Bishop Clark
Modified: 2008-12-11 13:18 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-25 21:20:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bishop Clark 2006-03-24 10:33:29 EST
Description of problem:
sendmail 8.12.11-4.24.1.legacy is an upgrade offered for sendmail 8.12.8-9.90,
but it does not offer the /usr/lib/sendmail which is found in the older sendmail
package, and required by several apps -- usermin and bugzilla, to name the first
two affecting me.

Version-Release number of selected component (if applicable):
8.12.11-4.24.1.legacy

How reproducible:
always

Steps to Reproduce:
1. install sendmail 8.12.8-9.90
2. install usermin, bugzilla, etc
3. upgrade to sendmail 8.12.11-4.24.1.legacy
  
Actual results:
bugzilla cannot use sendmail and gives errors for whineatnew.pl and others.

Expected results:
bugzilla functions normally as before

Additional info:
rpm -q --dump sendmail (8.12.11-4.24.1.legacy)
/usr/lib/sendmail.sendmail 16 1143091985 00000000000000000000000000000000
0120777 root root 0 0 0 ../sbin/sendmail

rpm -q --dump sendmail (8.12.8-9.90)
/usr/lib/sendmail 16 1063824322 00000000000000000000000000000000 0120777 root
root 0 0 27241 ../sbin/sendmail

in BOTH cases, 'alternatives --config mta' gives:

There are 1 programs which provide 'mta'.

  Selection    Command
-----------------------------------------------
*+ 1           /usr/sbin/sendmail.sendmail
Comment 1 Jesse Keating 2006-03-24 11:34:19 EST
As a workaround, you can link /usr/lib/sendmail.sendmail to /usr/lib/sendmail

I'm investigating this.
Comment 2 Jesse Keating 2006-03-24 11:41:39 EST
/usr/sbin/alternatives --install %{_sbindir}/sendmail mta
%{_sbindir}/sendmail.sendmail 90 \
        --slave %{_bindir}/mailq mta-mailq %{_bindir}/mailq.sendmail \
        --slave %{_bindir}/newaliases mta-newaliases
%{_bindir}/newaliases.sendmail \
        --slave %{_bindir}/rmail mta-rmail %{_bindir}/rmail.sendmail \
        --slave /usr/lib/sendmail mta-sendmail /usr/lib/sendmail.sendmail \
        --slave %{_sysconfdir}/pam.d/smtp mta-pam
%{_sysconfdir}/pam.d/smtp.sendmail \
        --slave %{_mandir}/man8/sendmail.8.gz mta-sendmailman
%{_mandir}/man8/sendmail.sendmail.8.gz \
        --slave %{_mandir}/man1/mailq.1.gz mta-mailqman
%{_mandir}/man1/mailq.sendmail.1.gz \
        --slave %{_mandir}/man1/newaliases.1.gz mta-newaliasesman
%{_mandir}/man1/newaliases.sendmail.1.gz \
        --slave %{_mandir}/man5/aliases.5.gz mta-aliasesman
%{_mandir}/man5/aliases.sendmail.5.gz \
        --initscript sendmail


Thats in the spec for the RHL9 package, which should slave /usr/lib/sendmail to
the correct file.
Comment 3 Bishop Clark 2006-03-24 13:57:04 EST
For some reason, though, it's missing that step or undoing it:

[root@fishy root]# rpm -U sendmail_8.12.11-4.24.1.legacy_i386.rpm
warning: sendmail_8.12.11-4.24.1.legacy_i386.rpm: V3 DSA signature: NOKEY, key
ID 731002fa
warning: /etc/mail/sendmail.cf created as /etc/mail/sendmail.cf.rpmnew
warning: /etc/mail/sendmail.mc created as /etc/mail/sendmail.mc.rpmnew
warning: /etc/mail/submit.cf created as /etc/mail/submit.cf.rpmnew
warning: /etc/mail/submit.mc created as /etc/mail/submit.mc.rpmnew
warning: /etc/mail/statistics saved as /etc/mail/statistics.rpmsave
[root@fishy root]#
[root@fishy root]# ls -ld /usr/lib/sendmail*
lrwxrwxrwx    1 root     root           16 Mar 24 10:03
/usr/lib/sendmail.sendmail -> ../sbin/sendmail

It *should* be running that %post on install, so I can't easily see why I'm not
seeing its benefits.
Comment 4 Marc Deslauriers 2006-03-25 09:03:13 EST
Do you have /usr/sbin/alternatives installed on your system?
Comment 5 Marc Deslauriers 2006-03-25 09:04:25 EST
never mind. i just noticed comment 1.
Comment 6 Marc Deslauriers 2006-03-25 09:15:43 EST
How about the output of "alternatives --display mta"
Comment 7 Bishop Clark 2006-03-26 05:43:39 EST
Marc:  sorry for the delay.  The box is generally a package-worshipping RH9 box,
with stuff added but nothing missing nor replaced, generally.  So I should have
mostly everything expected.

Here's alternatives --display mta:

mta - status is auto.
 link currently points to /usr/sbin/sendmail.sendmail
/usr/sbin/sendmail.sendmail - priority 90
 slave mta-mailq: /usr/bin/mailq.sendmail
 slave mta-newaliases: /usr/bin/newaliases.sendmail
 slave mta-rmail: /usr/bin/rmail.sendmail
 slave mta-sendmail: /usr/lib/sendmail.sendmail
 slave mta-pam: /etc/pam.d/smtp.sendmail
 slave mta-sendmailman: /usr/share/man/man8/sendmail.sendmail.8.gz
 slave mta-mailqman: /usr/share/man/man1/mailq.sendmail.1.gz
 slave mta-newaliasesman: /usr/share/man/man1/newaliases.sendmail.1.gz
 slave mta-aliasesman: /usr/share/man/man5/aliases.sendmail.5.gz
Current `best' version is /usr/sbin/sendmail.sendmail.

I suspect we'll be stracing an rpm-U soon, eh?
Comment 8 Bishop Clark 2006-03-26 08:10:54 EST
*** Bug 186781 has been marked as a duplicate of this bug. ***
Comment 9 Bishop Clark 2006-03-26 08:58:22 EST
RE-invoking 'alternatives --auto mta' will get around this issue until a fix
arrives.


[root@fishy root]# rpm -Uvh sendmail*8.12.11-4.24*rpm
warning: sendmail_8.12.11-4.24.1.legacy_i386.rpm: V3 DSA signature: NOKEY, key
ID 731002fa
Preparing...                ########################################### [100%]
   1:sendmail-cf            ########################################### [ 50%]
   2:sendmail               warning: /etc/mail/sendmail.cf created as
/etc/mail/sendmail.cf.rpmnew
warning: /etc/mail/sendmail.mc created as /etc/mail/sendmail.mc.rpmnew
warning: /etc/mail/submit.cf created as /etc/mail/submit.cf.rpmnew
########################################### [100%]
[root@fishy root]# ls -l /etc/pam.d/smt*
-rw-r--r--    1 root     root          116 Mar 22 21:33 /etc/pam.d/smtp.sendmail
[root@fishy root]# ls -l /usr/lib/sendmail
ls: /usr/lib/sendmail: No such file or directory
[root@fishy root]# alternatives --display mta
mta - status is auto.
 link currently points to /usr/sbin/sendmail.sendmail
/usr/sbin/sendmail.sendmail - priority 90
 slave mta-mailq: /usr/bin/mailq.sendmail
 slave mta-newaliases: /usr/bin/newaliases.sendmail
 slave mta-rmail: /usr/bin/rmail.sendmail
 slave mta-sendmail: /usr/lib/sendmail.sendmail
 slave mta-pam: /etc/pam.d/smtp.sendmail
 slave mta-sendmailman: /usr/share/man/man8/sendmail.sendmail.8.gz
 slave mta-mailqman: /usr/share/man/man1/mailq.sendmail.1.gz
 slave mta-newaliasesman: /usr/share/man/man1/newaliases.sendmail.1.gz
 slave mta-aliasesman: /usr/share/man/man5/aliases.sendmail.5.gz
Current `best' version is /usr/sbin/sendmail.sendmail.
[root@fishy root]# alternatives --auto mta
[root@fishy root]# ls -l /usr/lib/sendmail*
lrwxrwxrwx    1 root     root           30 Mar 26 06:01 /usr/lib/sendmail ->
/etc/alternatives/mta-sendmail
lrwxrwxrwx    1 root     root           16 Mar 26 05:58
/usr/lib/sendmail.sendmail -> ../sbin/sendmail
[root@fishy root]# ls -l /etc/pam.d/smt*
lrwxrwxrwx    1 root     root           25 Mar 26 06:01 /etc/pam.d/smtp ->
/etc/alternatives/mta-pam
-rw-r--r--    1 root     root          116 Mar 22 21:33 /etc/pam.d/smtp.sendmail
Comment 10 Marc Deslauriers 2006-03-26 09:58:12 EST
There are new packages that correct this issue awaiting QA in bug 186277.
Comment 11 Marc Deslauriers 2006-03-26 09:59:46 EST
*** Bug 186783 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.