Bug 1868103 - Serverless Knative Eventing CR should be marked tech preview
Summary: Serverless Knative Eventing CR should be marked tech preview
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Jaivardhan Kumar
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1869967
TreeView+ depends on / blocked
 
Reported: 2020-08-11 17:09 UTC by Jaivardhan Kumar
Modified: 2020-10-27 16:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1869967 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:27:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6298 0 None closed Bug 1868103: adds badge support for KnativeEventing creation 2020-09-02 14:26:25 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:27:56 UTC

Description Jaivardhan Kumar 2020-08-11 17:09:07 UTC
Description of problem:
OpenShift Serverless is GA, but it contains a part, Knative Eventing, that it's still tech preview. Knative Eventing CR should be marked with tech preview badge. Knative Serving CR shouldn't have tech preview badge as it's fully supported.

Prerequisites (if any, like setup, operators/versions):
Install Serverless 1.7.1 on OCP 4.4 or OCP 4.5 or OCP 4.6 nightly builds

Steps to Reproduce
- Install Serverless
- Go to installed operators and choose Knative Eventing from list of provided APIs

Actual results:
Knative Eventing don't have a tech preview badge.

Expected results:
Knative Eventing should have a tech preview badge.

Reproducibility (Always/Intermittent/Only Once):
Always

Build Details:
OCP 4.5.0, Serverless 1.7.x
OCP 4.4.10, Serverless 1.7.x

Comment 3 Gajanan More 2020-08-24 10:15:31 UTC
I can see the Tech-Preview badge. 
I have validated the bugzilla on:
Build: 4.6.0-0.nightly-2020-08-23-214712
Browser: Google Chrome version 84.0.4147.89
Marking the bugzilla as verified

Comment 4 Gajanan More 2020-08-24 10:18:32 UTC
I can see the Tech-Preview badge. 
I have validated the bugzilla on:
Build: 4.6.0-0.nightly-2020-08-23-214712
Browser: Google Chrome version 84.0.4147.89
Marking the bugzilla as verified

Comment 6 errata-xmlrpc 2020-10-27 16:27:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.