Bug 1868358 - Pipelinerun fails if we select `Empty Directory` as value for workspace from devconsole UI
Summary: Pipelinerun fails if we select `Empty Directory` as value for workspace from ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.6.0
Assignee: divgupta
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1870585
TreeView+ depends on / blocked
 
Reported: 2020-08-12 11:42 UTC by divgupta
Modified: 2020-10-27 16:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-27 16:28:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
Pipelinerun passes if we select `Empty Directory` as value for workspace from devconsole UI-1 (68.99 KB, image/png)
2020-08-24 10:40 UTC, spathak@redhat.com
no flags Details
Pipelinerun fails if we select `Empty Directory` as value for workspace from devconsole UI-2 (65.32 KB, image/png)
2020-08-24 10:40 UTC, spathak@redhat.com
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 6300 0 None closed Bug 1868358: Fix pipeline workspace volume-type empty-directory 2020-09-24 14:36:00 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:28:21 UTC

Description divgupta 2020-08-12 11:42:12 UTC
Description of problem:
Pipelinerun fails if we select `Empty Directory` as value for workspace from devconsole UI

How reproducible: Always

Steps to Reproduce:
1.Create a task which uses workspace
2.Create a pipeline from using the above task and include workspace in spec file 
3.From devconsole UI start the pipeline and for the workspace select Empty Directory for workspace

Actual results:
No value is provided for the workspace, the taskrun shows red exclamatory mark and the pipelinerun stays in running state

Expected results:
`emptyDir: {}` value should be provided for workspace and pipelinerun should start and succeed

Comment 3 spathak@redhat.com 2020-08-24 10:40:12 UTC
Created attachment 1712333 [details]
Pipelinerun passes if we select `Empty Directory` as value for workspace from devconsole UI-1

Comment 4 spathak@redhat.com 2020-08-24 10:40:49 UTC
Created attachment 1712334 [details]
Pipelinerun fails if we select `Empty Directory` as value for workspace from devconsole UI-2

Comment 5 spathak@redhat.com 2020-08-24 10:43:58 UTC
Verified on Build version: 4.6.0-0.nightly-2020-08-23-214712
Browser version: Chrome 83

Comment 7 errata-xmlrpc 2020-10-27 16:28:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.