Bug 1870585 - Pipelinerun fails if we select `Empty Directory` as value for workspace from devconsole UI
Summary: Pipelinerun fails if we select `Empty Directory` as value for workspace from ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.5
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 4.5.z
Assignee: divgupta
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On: 1868358
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-20 12:30 UTC by OpenShift BugZilla Robot
Modified: 2020-09-21 17:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-21 17:42:05 UTC
Target Upstream Version:


Attachments (Terms of Use)
Pipelinerun does not fails if we select `Empty Directory` as value for workspace from devconsole UI (78.45 KB, image/png)
2020-09-16 22:33 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 6384 None closed [release-4.5] Bug 1870585: Fix pipeline workspace volume-type empty-directory 2020-09-21 13:22:03 UTC
Red Hat Product Errata RHBA-2020:3719 None None None 2020-09-21 17:42:21 UTC

Description OpenShift BugZilla Robot 2020-08-20 12:30:22 UTC
+++ This bug was initially created as a clone of Bug #1868358 +++

Description of problem:
Pipelinerun fails if we select `Empty Directory` as value for workspace from devconsole UI

How reproducible: Always

Steps to Reproduce:
1.Create a task which uses workspace
2.Create a pipeline from using the above task and include workspace in spec file 
3.From devconsole UI start the pipeline and for the workspace select Empty Directory for workspace

Actual results:
No value is provided for the workspace, the taskrun shows red exclamatory mark and the pipelinerun stays in running state

Expected results:
`emptyDir: {}` value should be provided for workspace and pipelinerun should start and succeed

Comment 3 spathak@redhat.com 2020-09-16 22:33:27 UTC
Created attachment 1715141 [details]
Pipelinerun does not fails if we select `Empty Directory` as value for workspace from devconsole UI

Comment 4 spathak@redhat.com 2020-09-16 22:37:12 UTC
Verified on build version: 4.5.0-0.ci-2020-09-15-143038
Browser version: Chrome 84

Comment 6 errata-xmlrpc 2020-09-21 17:42:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3719


Note You need to log in before you can comment on or make changes to this bug.