Bug 186907 - Anaconda ethernet selector dialogue box undisplayed
Anaconda ethernet selector dialogue box undisplayed
Status: CLOSED DUPLICATE of bug 185950
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-27 07:19 EST by David Howells
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-28 10:41:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Howells 2006-03-27 07:19:16 EST
Description of problem: 
 
Whilst doing an NFS installation, when I get to the ethernet interface 
selector screen, the dialogue box is *not* displayed, though it still accepts 
up/down to switch between eth0 and eth1, and F12 to advance to the next screen 
(nominating an NFS server). 
 
Version-Release number of selected component (if applicable): 
 
Base FC5. 
 
How reproducible: 
 
100%. 
 
Steps to Reproduce: 
1. Find a machine with two ethernet cards. 
2. Put in an FC5 install CD and boot. 
3. start the installation, select normal graphical installation, "English", 
"UK keyboard layout" and "NFS install" and go to the next screen after each 
selection. 
   
Actual results: 
 
I then observe a screen with no dialogue box displayed, though the footer that 
specifies keyboard shortcuts is there. Pressing F12 will attempt to contact a 
DHCP server through eth0; pressing Down, F12 will attempt to contact a DHCP 
server through eth1. 
 
Expected results: 
 
There should be an ethernet interface selector dialogue box displayed in that 
screen. 
 
Additional info:
Comment 1 Jeremy Katz 2006-03-27 13:37:24 EST
Does it show up if you hit ctrl-l?  What type of machine is this on?
Comment 2 David Howells 2006-03-28 05:27:01 EST
It was on warthog.cambridge.redhat.com (my desktop machine).  This is an 
Athlon64 machine and the distribution being used was x86_64. 
Comment 3 David Howells 2006-03-28 07:39:57 EST
Pressing ctrl-l has no effect. 
 
I don't see any error messages in the logs on tty3 and tty4 when the ethernet 
pick screen is displayed (I do see a line appear in the log saying that it's 
going to bring up the screen). 
Comment 4 Chris Lumens 2006-03-28 10:41:11 EST
This is likely a newt bug.  What I believe is happening is that the string for
the ethernet card is making the dialog too wide, so newt is unable to draw it on
the screen.  According to pnasrat, the string for one NIC on warthog is "eth0 -
National Semiconductor Corporation DP83815 (MacPhyter) Ethernet         
Controller".  With the padding, line drawing characters, etc. this puts us
pretty far over 80 columns.

I've seen this same behavior in firstboot, elsewhere in the loader under German
and Italian, and system-config-securitylevel.  See also bug 185950 for a
description of a problem that sounds a whole lot like yours.

*** This bug has been marked as a duplicate of 185950 ***

Note You need to log in before you can comment on or make changes to this bug.