Bug 185950 - Authconfig-tui present unusable screen under Polish locale set.
Authconfig-tui present unusable screen under Polish locale set.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: newt (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
:
: 186907 (view as bug list)
Depends On:
Blocks: 189981
  Show dependency treegraph
 
Reported: 2006-03-20 06:58 EST by MW
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.52.2-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 17:54:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Scrshot of authconfig being run with Polish Locale (under xterm) (18.51 KB, image/png)
2006-03-20 06:58 EST, MW
no flags Details
Proposed patch (1.49 KB, patch)
2006-03-28 15:41 EST, Tomas Mraz
no flags Details | Diff

  None (edit)
Description MW 2006-03-20 06:58:47 EST
Description of problem:
If Polish locale selected as system locale, the authconfig-tui presents no
useful screen on console. It consists only of blue bkg and movement tips at the
very last row of the screen (localized strings). However authconfig-tui reacts
on movement keys pressed ie. space, ESC or F12.
If it is run with C locale it presents full workable screen.

Version-Release number of selected component (if applicable):
authconfig-5.2.2-1

How reproducible:
After fresh install with no graphic desktops/X, when firstboot invokes
authconfig via setup or
on every run as root on console/xterm with Polish locale set.

Steps to Reproduce:
1.Fresh install with no X/Desktop and set Polish locale as system one, then
allow firstboot to invoke setup and authconfig. OR
2.Run it from command line or throuh setup tools on console/xterm as root.
  
Actual results:
Only unusable blue screen.

Expected results:
Usable screen with options to check/uncheck to set up authentication of the system.

Additional info:
Comment 1 MW 2006-03-20 06:58:47 EST
Created attachment 126345 [details]
Scrshot of authconfig being run with Polish Locale (under xterm)
Comment 2 Tomas Mraz 2006-03-20 09:02:12 EST
Seems to be a newt toolkit problem as it works fine with the same authconfig
version on FC-4.

Workaround - make the terminal window wider.
Comment 3 MW 2006-03-21 01:01:47 EST
Hmm??? Make a terminal window wider.... But it also happens in bare console
outside xterm.. It happens during firstboot in text mode. Setting higher VGA
mode in console doesn't help.
Comment 4 Chris Lumens 2006-03-28 10:41:36 EST
*** Bug 186907 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2006-03-28 11:32:14 EST
This is a problem that's turned up in the text parts of the installer (ethernet
device screen, partitioning screen), firstboot, and various configuration tools.
 What we've determined matches up with what Tomas says - the text is too large
for the terminal, so newt simply doesn't draw the dialog on the screen.  This is
a regression from FC4.

Attached is a reproducer in python for this bug.  Make sure your terminal is
under 200 columns.  Note that we can't resize the console, so this is a big
problem for us.

#!/usr/bin/python

from snack import *

li = Listbox(5, returnExit = 1)
li.append("a"*200, "f")
screen = SnackScreen()
g = Grid(1, 3)
g.setField(li, 0, 1, (0, 1, 0, 1))
g.place(1, 1)
screen.gridWrappedWindow(g, "title")
f = Form("This is some help")
f.add(li)
res = f.run()
screen.popWindow()
screen.finish()
Comment 6 Tomas Mraz 2006-03-28 15:41:41 EST
Created attachment 126932 [details]
Proposed patch

This patch fixes the regression.
Comment 7 Petr Rockai 2006-04-03 17:54:20 EDT
Thanks Tom for the patch. An updated newt resolving this issue has been 
pushed to fc5 updates.

Note You need to log in before you can comment on or make changes to this bug.