Bug 1869310 - CoreDNS pods observing panic without any provbe failures
Summary: CoreDNS pods observing panic without any provbe failures
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: DNS
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.z
Assignee: Stephen Greene
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On: 1869309
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-17 13:20 UTC by OpenShift BugZilla Robot
Modified: 2020-09-22 06:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Running CoreDNS 1.6.6 Consequence: Intermittent `invalid memory address or nil pointer dereference` followed by timeouts in kube API access Fix: Backport CoreDNS#4022 to OCP, which fixes handling errors with Endpoint Tombstones. Result: CoreDNS behaves as intended without intermittent panics.
Clone Of:
Environment:
Last Closed: 2020-09-22 06:58:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift coredns pull 39 None closed [release-4.4] Bug 1869310: Back port Handle endpoint tombstones (upstream #3887) 2020-09-25 10:33:51 UTC
Red Hat Knowledge Base (Solution) 5175271 None None None 2020-08-31 09:25:02 UTC
Red Hat Product Errata RHBA-2020:3715 None None None 2020-09-22 06:59:00 UTC

Comment 1 Stephen Greene 2020-08-20 15:50:54 UTC
Adding upcoming spring while this backport awaits it's parent BZ to be verified.

Comment 4 Hongan Li 2020-09-14 08:39:08 UTC
verified with 4.4.0-0.nightly-2020-09-12-055214 and passed

Comment 7 errata-xmlrpc 2020-09-22 06:58:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.4.23 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3715


Note You need to log in before you can comment on or make changes to this bug.