Bug 1869309 - CoreDNS pods observing panic without any provbe failures
Summary: CoreDNS pods observing panic without any provbe failures
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: DNS
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.z
Assignee: Stephen Greene
QA Contact: Hongan Li
URL:
Whiteboard:
Depends On: 1868315
Blocks: 1869310
TreeView+ depends on / blocked
 
Reported: 2020-08-17 13:19 UTC by OpenShift BugZilla Robot
Modified: 2020-09-20 13:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Running CoreDNS 1.6.6 Consequence: Intermittent `invalid memory address or nil pointer dereference` followed by timeouts in kube API access Fix: Backport CoreDNS#4022 to OCP, which fixes handling errors with Endpoint Tombstones. Result: CoreDNS behaves as intended without intermittent panics.
Clone Of:
Environment:
Last Closed: 2020-09-08 10:54:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift coredns pull 38 None closed [release-4.5] Bug 1869309: Back port Handle endpoint tombstones (upstream #3887) 2020-09-20 15:29:34 UTC
Red Hat Product Errata RHBA-2020:3510 None None None 2020-09-08 10:55:15 UTC

Comment 3 Hongan Li 2020-08-24 04:07:49 UTC
verified with 4.5.0-0.nightly-2020-08-20-031121 and no regression/panic during the test. moving to verified.

Comment 5 errata-xmlrpc 2020-09-08 10:54:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.8 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3510


Note You need to log in before you can comment on or make changes to this bug.