Bug 186970 - gthumb built without libiptcdata support
gthumb built without libiptcdata support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gthumb (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
Depends On: Merge
Blocks: PPC64MissingDeps
  Show dependency treegraph
 
Reported: 2006-03-27 14:23 EST by David Moore
Modified: 2009-09-21 15:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-05 01:54:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to gthumb's spec file (926 bytes, patch)
2006-04-12 23:20 EDT, David Moore
no flags Details | Diff
spec file for libiptcdata (1.72 KB, text/plain)
2006-04-12 23:22 EDT, David Moore
no flags Details

  None (edit)
Description David Moore 2006-03-27 14:23:01 EST
gthumb has the ability to store image metadata in the image file itself using
the libiptcdata library.  This feature is very useful, and is automatically
enabled if the libiptcdata library is present when gthumb is built.

The only bug here is that libiptcdata should be packaged, and made a
prerequisite for gthumb.  This should be trivial since libiptcdata already comes
with a spec file and has few prerequisities.
Comment 1 David Moore 2006-04-12 23:20:31 EDT
Created attachment 127690 [details]
Patch to gthumb's spec file
Comment 2 David Moore 2006-04-12 23:22:15 EDT
Created attachment 127691 [details]
spec file for libiptcdata

I've attached a patch to gthumb's spec file along with a spec file for
libiptcdata to make the suggested changes.  I've tested them under FC5 and they
work as intended.
Comment 3 Matthias Clasen 2006-08-02 23:43:55 EDT
Too late for FC6. Putting on FC7Target
Comment 4 Niels 2006-08-03 02:07:32 EDT
Sad, as it is such a simple working fix that has been available for some time.
Well, another half a year of building  gthumb myself.
Comment 5 David Moore 2007-03-27 21:59:36 EDT
libiptcdata is now available in Fedora Extras, so it should be easy to apply
this patch to the gthumb spec file now.
Comment 6 Behdad Esfahbod 2007-04-02 14:03:54 EDT
(In reply to comment #5)
> libiptcdata is now available in Fedora Extras, so it should be easy to apply
> this patch to the gthumb spec file now.

Or after the Core and Extras merge is complete.
Comment 7 Matthias Clasen 2007-04-17 12:42:52 EDT
Moving off FC7Target
Comment 8 Bill Nottingham 2007-05-04 23:16:02 EDT
libiptcdata.ppc64 is now available.
Comment 9 Matthias Clasen 2007-05-05 01:54:49 EDT
Built

Note You need to log in before you can comment on or make changes to this bug.