Bug 187078 - allow configurable killproc timeout
Summary: allow configurable killproc timeout
Status: CLOSED DUPLICATE of bug 198429
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature, Reopened
Depends On:
Blocks: 184403
TreeView+ depends on / blocked
 
Reported: 2006-03-28 10:43 UTC by Joe Orton
Modified: 2014-03-17 02:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-30 17:02:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joe Orton 2006-03-28 10:43:17 UTC
Description of problem:
When shutdown by the init script, httpd has a race between the parent killing
the children, and the parent being killed by the SIGKILL from killproc.  If
there is a lazy/stuck child which refuses to die, killproc may win the race,
SIGKILL the parent, and leave orphaned children.  This is Undesirable Behaviour
(TM). 

This can be eliminated by allowing the httpd init script to specify the time
before the SIGKILL is sent.

(this is an RFE which I will hopefully get round to attaching a patch to RSN)

Comment 1 Miloslav Trmač 2006-07-29 00:04:39 UTC

*** This bug has been marked as a duplicate of 198429 ***

Comment 2 Joe Orton 2006-07-29 06:47:47 UTC
This is requested in RHEL4 to fix a bug in httpd, it's not just a feature. 
Otherwise I will have to duplicate all of killproc() in the httpd init script or
something.

Comment 3 Miloslav Trmač 2006-07-29 10:44:13 UTC
I'm sorry, it was filed against rawhide, so I had no way to know that.

Comment 4 Joe Orton 2006-07-30 17:02:53 UTC
Oh, sorry, my mistake - I forgot this was filed against Raw Hide, there is
already a separate RHEL4 bug (bug 198468).  Closing this again.

*** This bug has been marked as a duplicate of 198429 ***


Note You need to log in before you can comment on or make changes to this bug.