Bug 198429 - configurable delay for killproc()
configurable delay for killproc()
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 187078 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-11 07:48 EDT by Joe Orton
Modified: 2014-03-16 23:00 EDT (History)
1 user (show)

See Also:
Fixed In Version: 8.36-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-20 11:44:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
killproc patch (1.01 KB, patch)
2006-07-11 07:48 EDT, Joe Orton
no flags Details | Diff
tab-fixed patch (1.00 KB, patch)
2006-07-11 07:51 EDT, Joe Orton
no flags Details | Diff

  None (edit)
Description Joe Orton 2006-07-11 07:48:28 EDT
Description of problem:
I'll attach a patch which makes the delay between doing a SIGTERM and a SIGKILL
in killproc() configurable.

This can be used to fix a race condition in httpd shutdown.  The httpd parent
will SIGTERM then SIGKILL children at shutdown in a similar way to how
killproc() will SIGTERM and then SIGKILL the httpd parent.  But these two race
and sometimes the parent will get SIGKILLed before it manages to kill all its
children.  This can leave orphans.

So making the killproc() delay configurable means we can ensure that httpd
always wins this race and cleans up its children before the parent gets cleaned up.

See also bug 184403.
Comment 1 Joe Orton 2006-07-11 07:48:28 EDT
Created attachment 132229 [details]
killproc patch
Comment 2 Joe Orton 2006-07-11 07:51:53 EDT
Created attachment 132230 [details]
tab-fixed patch

replacement patch which uses tabs for whitespace
Comment 3 Bill Nottingham 2006-07-20 11:44:03 EDT
Added in CVS, will be in 8.36-1. Thanks!
Comment 4 Miloslav Trmač 2006-07-28 20:04:52 EDT
*** Bug 187078 has been marked as a duplicate of this bug. ***
Comment 5 Joe Orton 2006-07-30 13:03:16 EDT
*** Bug 187078 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.