Bug 187080 - relnotes unclear about IBM pSeries (Power) hardware support
relnotes unclear about IBM pSeries (Power) hardware support
Status: CLOSED NEXTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
ppc64 Linux
medium Severity high
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
:
Depends On:
Blocks: fc-relnotes-traqr
  Show dependency treegraph
 
Reported: 2006-03-28 06:14 EST by Nigel Griffiths
Modified: 2009-09-21 16:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-03 13:55:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Griffiths 2006-03-28 06:14:30 EST
The release notes stats that IBM pSeries machines, which has the POWER5
processors, are supported - great.

pSeries machines can be used in three ways:
1) Stand alone as a SMP machine.
2) Using Logical Partitions with physical resources like real SCSI disks and
Ethernet.
3) Using Logical Partitions with virtual resources like using ibmvscsi and
ibmveth drivers.

It is not clear in the release notes which modes are supported.

I have just tried virtual resources - failed with unable to read package
metadata, failure with a reference to repodata/comps.xml from anaconda Errno 256

I have just tried with physical resources - hangs loading a DAC960 driver, which
is a RAID SCSI card.

If you clarify which modes and hardware Fedora5 has been tested on, we might
avoid many frustrations in Fedora users.
Comment 1 Paul Nasrat 2006-03-28 11:54:29 EST
The release notes are wrong.

I've used genesis, lpar (full system partition), and lpar with vscsi. As well as
js20, js21.

For the DAC960 bug, boot with linux nostorage, select your scsi driver and it
should proceed - I'm trying to trace this issue (I'll add the bug number). 
Please  file bugs against anaconda on specific hardware configuration failures -
such as ibmvscsi and we'll try and reproduce.  The comment was originally
referring to rs6000 32bit, which is now supported also.

Comment 2 Paul W. Frields 2006-03-28 21:39:25 EST
Paul N, I don't know anyone on the docs team who is using this hardware, so if
you'd like to correspond with Luya to fix any problems, that would be appreciated.
Comment 3 Release Notes Tracker 2007-02-10 03:08:25 EST
Was this ever resolved?

Blocing master tracker so this doesn't get forgotten.
Comment 4 Paul W. Frields 2007-02-10 10:29:37 EST
I've added Paul N. and Jeremy to the CC list for this one since they're listed
as the dev POCs for the Installer release notes beat.  I don't know how
applicable this note is anymore, and since I don't think any of our Docs editors
have access to or experience with this hardware, they're probably best to
comment or close.
Comment 5 Karsten Wade 2007-02-10 12:30:49 EST
And when you all have decided what the answer is, please update the content
directly at:

http://fedoraproject.org/wiki/Docs/Beats/Installer

and/or

http://fedoraproject.org/wiki/Docs/Beats/ArchSpecific/PPC (?)
Comment 6 Luya Tshimbalanga 2007-02-10 17:28:56 EST
Or if you are too lazy to update the wiki, I will update the wiki once both
Jeremy and Paul N give more details. I confirm I never touched a IBM pSeries in
my lifetime.
Comment 7 Paul W. Frields 2007-04-08 12:37:21 EDT
I don't see that this was updated before test4.  There is a little time left to
get this in before we go to final.  (Refer to
http://fedoraproject.org/wiki/DocsProject/Schedule for details on deadlines.) 
The wiki beats are now editable by anyone in the EditGroup on the wiki, so if
anyone subscribed to this bug wants to see this changed, step up and do it. 
Don't worry about being grammatically perfect, as the Docs team will take care
of fixing your edits for you.  The appropriate page is:

http://fedoraproject.org/wiki/Docs/Beats/ArchSpecific/PPC
Comment 8 Luya Tshimbalanga 2008-04-27 01:05:41 EDT
Anyone with IBM pSeries confirm their system is working? This old bug should be
closed.
Comment 9 Jason Taylor 2008-08-28 11:10:32 EDT
After chatting with jwb, dwmw2 and jlaska our release notes are updated and this should ticket should now be resolved.

Note You need to log in before you can comment on or make changes to this bug.