Bug 187100 - network bridge broken
network bridge broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 194418 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-28 09:38 EST by Andrew Benham
Modified: 2014-03-16 22:59 EDT (History)
9 users (show)

See Also:
Fixed In Version: 8.31.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-08 21:44:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Benham 2006-03-28 09:38:59 EST
Description of problem:

Network bridge won't install at start time.  The interfaces on the
bridge can't be added to it.  No network :-(


Version-Release number of selected component (if applicable):

8.31.1-1


How reproducible:

Every time.


Steps to Reproduce:
1. Configure a bridge
2. Reboot
3.
  
Actual results:
Device br0 does not seem to be present, delaying initialization.
then one grumble per interface.
No network available.

Expected results:
Networking starts OK.

Additional info:

This is following an upgrade from FC4 to FC5.

It's something to do with the new code added to
    /etc/sysconfig/network-scripts/ifup-eth
In particular, I suspect, the use of 'is_available()' function from
network-functions.
'/sbin/ip -o link' doesn't show an entry for br0, so bad things happen.

My temporary fix is to comment out line 60 of ifup-eth:

     53 # now check the real state
     54 is_available ${REALDEVICE} || {
     55       if [ -n "$alias" ]; then
     56          echo $"$alias device ${DEVICE} does not seem to be present,
delaying initialization."
     57       else
     58          echo $"Device ${DEVICE} does not seem to be present, delaying
initialization."
     59       fi
     60       #%% exit 1
     61 }

but this can't be the right thing to do.
Comment 1 Miloslav Trmač 2006-03-28 12:57:38 EST
This should be already fixed in CVS.
Comment 2 Dan Naughton 2006-04-04 12:26:37 EDT
I tried this with the initscripts-8.31.2-1 from the development area an the
problem still exists.  I'm not familiar with CVS, but browsing the web interface
to it looked like 8.31.2-1 was the latest. (March 20th date on the rpm). 
Symptoms are the same.  I commented out the "exit 1" from above, and it seems to
make it through with some complaining.


# more ifcfg-br0
DEVICE=br0
TYPE=Bridge

# ./ifup br0
Device br0 does not seem to be present, delaying initialization.
Error for wireless request "Set Encode" (8B2A) :
    SET failed on device br0 ; No such device.
Comment 3 Miloslav Trmač 2006-04-04 13:21:44 EDT
In CVS means really the initscripts module at elvis.redhat.com, there is no Fedora
package yet.  I'll update this bug when new initscripts package is released.
Comment 4 Miloslav Trmač 2006-04-11 16:40:32 EDT
Should be fixed in rawhide initscripts-8.32-1.
Comment 5 Andreas Müller 2006-04-11 18:59:03 EDT
OK, initscripts-8.32-1 works for me.
Comment 6 Jima 2006-04-18 09:27:01 EDT
I had the same issue; initscripts-8.32-1 solved it.

Looking forward to the official update though. ;-)

Thanks!
Comment 7 J. David Rye 2006-05-10 12:49:29 EDT
I have the same problem I think

initscripts-8.31.1-1.src.rpm

Looking at the code, the paragraph to create the bridge device has been moved
below the call to is_available moving the bridge creation problem up solves the
problem.

Enableing the development repository and running yum update initscripts
fetches nitscripts.i386 0:8.33-1 which apears to have this change made. 
neither 8.32 or 8.33 have yet made it to the update area.... 
Comment 8 Miloslav Trmač 2006-07-08 21:40:37 EDT
*** Bug 194418 has been marked as a duplicate of this bug. ***
Comment 9 Miloslav Trmač 2006-07-08 21:44:05 EDT
Bill has released initscripts-8.31.5-1 for FC-5, which should fix this.

Note You need to log in before you can comment on or make changes to this bug.