Bug 1871873 - Refresh pools job NPE caused by derived pool
Summary: Refresh pools job NPE caused by derived pool
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 3.1
Hardware: noarch
OS: Linux
urgent
high
Target Milestone: ---
: ---
Assignee: Chris "Ceiu" Rog
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1881181
TreeView+ depends on / blocked
 
Reported: 2020-08-24 14:16 UTC by Tom Simmons
Modified: 2020-09-21 17:35 UTC (History)
4 users (show)

Fixed In Version: candlepin-3.1.19-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1881181 (view as bug list)
Environment:
Last Closed: 2020-08-31 11:06:01 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github candlepin candlepin pull 2784 0 None closed [M] 1871873: Fixed an NPE during refresh when adding new derived products (ENT-2785) 2021-02-08 10:31:24 UTC

Description Tom Simmons 2020-08-24 14:16:51 UTC
Description of problem:

Every execution of a refresh pools job for organization 11551121 fails in production due to a null pointer exception (see https://docs.google.com/document/d/1Ka2Ct1MYA8fleSLlI8CnyZVeV7DrFFTbme5lU5J1azs/edit?usp=sharing)

The root cause on most stack traces is elided, possibly because of a JVM optimization. The root cause is included in older stack traces on splunk and appears to indicate that a derived product or its ID is null for either the master pool or an existing pool, as noted in the document above.

Find the stack trace on 2020-AUG-18 in splunk: `candlepin_hosts(env=prod)` job=8a85f99173e8810e0173ee37a4a03d4a | transaction job

Version-Release number of selected component (if applicable): 3.1.16
How reproducible: Always for org 11551121, but reason is unknown.

Note also that this is associated with INC: https://redhat.service-now.com/surl.do?n=INC1397105


Note You need to log in before you can comment on or make changes to this bug.