Bug 1881181 - Refresh pools job NPE caused by derived pool
Summary: Refresh pools job NPE caused by derived pool
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 2.9
Hardware: noarch
OS: Linux
urgent
high
Target Milestone: ---
: 2.9
Assignee: Chris "Ceiu" Rog
QA Contact:
URL:
Whiteboard:
Depends On: 1871873
Blocks: 1881186
TreeView+ depends on / blocked
 
Reported: 2020-09-21 17:35 UTC by Chris "Ceiu" Rog
Modified: 2020-09-22 09:00 UTC (History)
5 users (show)

Fixed In Version: candlepin-2.9.30-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1871873
Environment:
Last Closed: 2020-09-22 09:00:24 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github candlepin candlepin pull 2812 0 None closed [2.9] 1881181: Fixed an NPE during refresh when adding new derived products 2020-10-19 15:52:41 UTC

Internal Links: 1881186

Description Chris "Ceiu" Rog 2020-09-21 17:35:02 UTC
+++ This bug was initially created as a clone of Bug #1871873 +++

Description of problem:

Every execution of a refresh pools job for organization 11551121 fails in production due to a null pointer exception (see https://docs.google.com/document/d/1Ka2Ct1MYA8fleSLlI8CnyZVeV7DrFFTbme5lU5J1azs/edit?usp=sharing)

The root cause on most stack traces is elided, possibly because of a JVM optimization. The root cause is included in older stack traces on splunk and appears to indicate that a derived product or its ID is null for either the master pool or an existing pool, as noted in the document above.

Find the stack trace on 2020-AUG-18 in splunk: `candlepin_hosts(env=prod)` job=8a85f99173e8810e0173ee37a4a03d4a | transaction job

Version-Release number of selected component (if applicable): 3.1.16
How reproducible: Always for org 11551121, but reason is unknown.

Note also that this is associated with INC: https://redhat.service-now.com/surl.do?n=INC1397105


Note You need to log in before you can comment on or make changes to this bug.