Bug 187248 - Anaconda doesn't recognize 3c905 network card in laptop
Anaconda doesn't recognize 3c905 network card in laptop
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-29 10:26 EST by Jared Smith
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-31 11:34:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "lspci" (876 bytes, text/plain)
2006-03-29 10:26 EST, Jared Smith
no flags Details
Output of "lspci -n" (441 bytes, text/plain)
2006-03-29 10:28 EST, Jared Smith
no flags Details

  None (edit)
Description Jared Smith 2006-03-29 10:26:17 EST
Description of problem:

Anaconda in FC5 doesn't recognize the network card in my Dell Lattitude C510
during the install, even though FC3 and FC4 have worked previously.  (I'm doing
a network-install, for what it's worth.)

Version-Release number of selected component (if applicable):

FC5

How reproducible:

Every time

Steps to Reproduce:
1. PXE boot the FC5 install image, selecting language and keyboard
2. Choose the HTTP install method
3. Anaconda claims it can't find any NICs
4. Tell Anaconda to load the 3c59x module
5. Watch Anaconda still fail to find any NICs
  
Actual results:
Anaconda never finds the NIC

Expected results:
Anacond finds the NIC and allows me to do a network install

Additional info:
Under RHEL4.3, this card works fine with the 3c59x kernel module.  I'll attach
the output of both "lspci" and "lspci -n" to this bug report
Comment 1 Jared Smith 2006-03-29 10:26:18 EST
Created attachment 126992 [details]
Output of "lspci"
Comment 2 Jared Smith 2006-03-29 10:28:43 EST
Created attachment 126993 [details]
Output of "lspci -n"
Comment 3 Jared Smith 2006-03-29 15:37:20 EST
I can confirm that FC3T5 works fine on this laptop.  It seems something must
have changed between Test 3 and the release of FC5.  If there's anything else
you'd like me to test, I'd be happy to try it out... In the meantime, I'll do a
"yum update" from Test 3 to FC5.  (It may take a while, as I'm on a slow network
this week.)
Comment 4 Rutger Noot 2006-04-29 10:46:08 EDT
I experience the same problem with a NE2000 compatible pcmcia network card. 
1. Boot from the boot.iso image
2. Choose the NFS/HTTP/FTP install method
3. Anaconda claims it can't find any NICs
4. Tell Anaconda to load the pcnet_cs module
5. Watch Anaconda still fail to find any NICs

I tried replacing the kernel on the boot disk with the latest FC5 kernel
(2.6.16-1.2096_FC5.i686) and the corresponding modules, but to no avail. 
However, running that kernel on my current system (FC3), the network card works!
I would therefore suggest that this is not a kernel issue, but a bug in the
anaconda loader. 
Comment 5 Dave Jones 2006-10-16 14:37:20 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 6 Jared Smith 2006-10-31 11:34:50 EST
I no longer have access to this hardware, and since FC6 is out, I say we go
ahead and close out this bug.

Note You need to log in before you can comment on or make changes to this bug.