Bug 187257 - segmentation faults with multiple include virtual php requests
Summary: segmentation faults with multiple include virtual php requests
Status: CLOSED DUPLICATE of bug 187253
Alias: None
Product: Fedora Legacy
Classification: Retired
Component: php   
(Show other bugs)
Version: fc3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Fedora Legacy Bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-03-29 16:44 UTC by Roman Veretelnikov
Modified: 2007-04-18 17:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-31 11:04:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
PHP Bug Tracker 35571 None None None Never

Description Roman Veretelnikov 2006-03-29 16:44:38 UTC
Description of problem:
php cause a segmentation fault when I try to include some PHP script
with more than one Apache's "include virtual".

Version-Release number of selected component (if applicable):
mod_php php-4.3.11-2.8
httpd-2.0.53-3.4.legacy or httpd-2.0.53-3.3

How reproducible:
Always

Steps to Reproduce:
1.
- test.html
<html>
<body>
<!--#include virtual="test.php" -->
<!--#include virtual="test.php" -->
</body>
</html>

- test.php
<? echo 'TEST'; ?>
2.
3.
  
Actual results:
With only one "include virtual" all works fine. With the two include virtual the 
Apache child process exits with segmentation fault after the output of the first 
include.

Expected results:


Additional info:
After downgrade to httpd-2.0.52-3 everything works fine.

Comment 1 Rahul Sundaram 2006-03-31 11:04:43 UTC

*** This bug has been marked as a duplicate of 187253 ***


Note You need to log in before you can comment on or make changes to this bug.