Bug 187253 - segmentation faults with multiple include virtual php requests
segmentation faults with multiple include virtual php requests
Status: CLOSED CANTFIX
Product: Fedora Legacy
Classification: Retired
Component: php (Show other bugs)
fc3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Fedora Legacy Bugs
:
: 187256 187257 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-29 11:15 EST by Roman Veretelnikov
Modified: 2007-04-18 13:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 15:15:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
PHP Bug Tracker 35029 None None None Never

  None (edit)
Description Roman Veretelnikov 2006-03-29 11:15:47 EST
Description of problem:
php cause a segmentation fault when I try to include some PHP script
with more than one Apache's "include virtual".

Version-Release number of selected component (if applicable):
mod_php php-4.3.11-2.8
httpd-2.0.53-3.4.legacy

How reproducible:
Always

Steps to Reproduce:
1.
- test.html
<html>
<body>
<!--#include virtual="test.php" -->
<!--#include virtual="test.php" -->
</body>
</html>

- test.php
<? echo 'TEST'; ?>
2.
3.
  
Actual results:
With only one "include virtual" all works fine. With the two include virtual the 
Apache child process exits with segmentation fault after the output of the first 
include.

Expected results:


Additional info:
After downgrade to httpd-2.0.52-3 everything works fine.
Comment 1 Rahul Sundaram 2006-03-31 06:04:46 EST
*** Bug 187257 has been marked as a duplicate of this bug. ***
Comment 2 Rahul Sundaram 2006-03-31 06:04:48 EST
*** Bug 187256 has been marked as a duplicate of this bug. ***
Comment 3 Roman Veretelnikov 2006-04-05 04:58:06 EDT
Seems like patch fix this issue:
diff -ur php-4.3.11.orig/sapi/apache2handler/sapi_apache2.c php-4.3.11/sapi/
apache2handler/sapi_apache2.c
--- php-4.3.11.orig/sapi/apache2handler/sapi_apache2.c  2006-04-05 12:09:32.
000000000 +0400
+++ php-4.3.11/sapi/apache2handler/sapi_apache2.c       2006-04-05 12:10:42.
000000000 +0400
@@ -530,7 +530,7 @@
 zend_first_try {

        ctx = SG(server_context);
-       if (ctx == NULL) {
+       if (ctx == NULL || (ctx && ctx->request_processed && !strcmp(r-
>protocol, "INCLUDED"))) {
                ctx = SG(server_context) = apr_pcalloc(r->pool, sizeof(*ctx));
                /* register a cleanup so we clear out the SG(server_context)
                 * after each request. Note: We pass in the pointer to the

http://cvs.php.net/viewcvs.cgi/php-src/sapi/apache2handler/sapi_apache2.c?r1=1.
1.2.40.2.8&r2=1.1.2.40.2.9&pathrev=PHP_4_4
Comment 5 Matthew Miller 2007-04-10 15:15:03 EDT
Fedora Core 3 is now completely unmaintained. These bugs can't be fixed in that
version. If the issue still persists in current Fedora Core, please reopen.
Thank you, and sorry about this.

Note You need to log in before you can comment on or make changes to this bug.