Bug 187281 - Installer fails with exception when upgrade from FC4
Installer fails with exception when upgrade from FC4
Status: CLOSED DUPLICATE of bug 185853
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-29 13:58 EST by WaldiMen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-29 14:01:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Exception dump (114.92 KB, text/plain)
2006-03-29 13:58 EST, WaldiMen
no flags Details

  None (edit)
Description WaldiMen 2006-03-29 13:58:36 EST
Installer fails with exception after choosing upgrade from existing FC4 system.
Whole exception text is attached

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 951, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 146, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 217, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 273, in upgradeMountFilesystems
    allowDirty = 0)
  File "/usr/lib/anaconda/upgrade.py", line 147, in mountRootPartition
    oldfsset.mountFilesystems(instPath, readOnly = readOnly)
  File "/usr/lib/anaconda/fsset.py", line 1637, in mountFilesystems
    entry.mount(instPath, readOnly = readOnly)
  File "/usr/lib/anaconda/fsset.py", line 1840, in mount
    BindMountDevice))
  File "/usr/lib/anaconda/fsset.py", line 1050, in mount
    raise SystemError (errNum, errMsg)
UnboundLocalError: local variable 'errNum' referenced before assignment

Local variables in innermost frame:
device: /dev/hda1
bindMount: False
readOnly: 0
self: <fsset.AutoFileSystem instance at 0xb7dade6c>
mountpoint: /mnt/sysimage//mnt/diskc
Comment 1 WaldiMen 2006-03-29 13:58:37 EST
Created attachment 127012 [details]
Exception dump
Comment 2 Chris Lumens 2006-03-29 14:01:24 EST

*** This bug has been marked as a duplicate of 185853 ***

Note You need to log in before you can comment on or make changes to this bug.