Bug 187309 - Laptop doesn't wake up after going to sleep
Laptop doesn't wake up after going to sleep
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-03-29 16:21 EST by Eugenia Loli-Queru
Modified: 2015-01-04 17:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-24 18:06:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Eugenia Loli-Queru 2006-03-29 16:21:05 EST
Description of problem:
Laptop goes to sleep using Gnome Power Manager (when closing the LID). Then,
when trying to wake it up by opening the LID, the fan starts and spins like
crazy, the LCD remains black and the keyboard does not respond (only the power
button works when keep pressing it which resets the machine).

Version-Release number of selected component (if applicable):

How reproducible:
Every time.

Expected results:
To wake up the way Macs do.

Additional info:
Here are some info on my laptop as given by Debian:
My laptop is a "Linux Certified" brand, 2.8 GHz P4, Radeon 9000 using the
default XORG r200 driver at 24bit color (1400x1050).

If you require new diagnostics, please guide me in detail how to acquire them
within FC5 and I will post them here.
Comment 1 Phil Knirsch 2006-07-18 11:59:06 EDT
That sounds more like a kernel bug if the machine doesn't react anymore.

The component acpid is only for bugs related to the userland acpi daemon.


Read ya, Phil
Comment 2 Eugenia Loli-Queru 2006-07-18 12:03:34 EDT
ACPI works and the laptop does not crash if I add s3_bios in the kernel
parameter line. But such a thing is almost impossible to know, it took me 2
YEARS before I tried that out and it worked (I only tried it 2 months ago for
the first time). I want out of the box support for my laptop. I need the kernel
or the installer to figure out that this s3_bios thing is required and either
the kernel on the fly use it by default, or simply fix the problem, or whatever.
But relying to the user to figure something like this out, is out of the question.
Comment 3 Dave Jones 2006-10-16 20:39:10 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 4 Dave Jones 2006-11-24 18:06:09 EST
This bug has been mass-closed along with all other bugs that
have been in NEEDINFO state for several months.

Due to the large volume of inactive bugs in bugzilla, this
is the only method we have of cleaning out stale bug reports
where the reporter has disappeared.

If you can reproduce this bug after installing all the
current updates, please reopen this bug.

If you are not the reporter, you can add a comment requesting
it be reopened, and someone will get to it asap.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.