Bug 18731 - GUI install on an S3 Savage4 8MB blows chunks
GUI install on an S3 Savage4 8MB blows chunks
Status: CLOSED DUPLICATE of bug 17991
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2000-10-09 13:53 EDT by Panic
Modified: 2007-04-18 12:29 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-12-13 13:36:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Panic 2000-10-09 13:53:17 EDT
... literally.  The X display immediately corrupts itself on the Disk Druid
setup screen.  Chunks of the display are repeated randomly across the top
half of the screen.  The installer still functions, but it is near
impossible to make out anything remotely resembling the installer unless
you continually click the Show Help/Hide Help button, which redraws the
window enough so that you can see it.  Also, there is black space along the
edges of the window where there shouldn't be.

Machine is a IBM Intellistation M Pro model 6889-78U, 128MB, 4GB SCSI
drive, aic7xxx SCSI adapter (the on-board 2940UW, I forget the
designation).  The X server in use is SVGA, utilizing the s3_savage driver.
 Also, on the first virtual console, I have this error repeated 3 times:

Gtk-CRITICAL **: file gtkaccelgroup.c: line 188 (gtk_accel_group_attach):
assertion 'g_slist_find (accel_group->attach_objects, object) == NULL' failed

I don't know if that is related or not.  The machine is available for
examination at your convenience.

Comment 1 Harshal Pradhan 2000-10-09 14:48:14 EDT
This might be related ....
I am having problems with an S3 Savage4 too. The machine is an IBM 300GL
workstation. Installed in text mode over ftp so I didnt have the installatin
problem. The card and monitor got detected accurately. Selected 1024x768
resolution with 24 bit color. X starts up with a gdm screen correctly. But
display does seemingly "blow up into chunks" when I log in (right after the
"gnome hint" appears) tried reducing the resolution and color depth. Didnt help.
The only way I found to make the system usable was turn of X accelaration with
Option no_accel in XF86config. But of course the performance is then very very
bad. I had no similar problems with Mandrake 7.1 that was running on the system
Comment 2 Panic 2000-10-09 17:09:07 EDT
I also got the video corruption after booting up and logging in.  I used:

Option "noaccel"

Under the S3 Savage4 (generic) Graphics device section in XF86Config, and that
worked, similar to keeda's fix (does it matter, no_accel or noaccel?).
Performance, of course, is not that great now.

Ruminating, I'd wager this is related to running XFree 3.3.6 against the 4.0

Comment 3 Alan Cox 2000-10-10 10:38:28 EDT
No this will be a server problem. You can however test if its a problem with the
3.x or 4.x server by
running Xconfigurator and choosing the server you wish (see man Xconfigurator).
It may be there is a bug in the 3.x or 4.x server we ship.
Comment 4 Harshal Pradhan 2000-10-10 12:58:56 EDT
AFAIK there is no support for Savage4 in 4.x yet. Xconfigurator seems to be
doing the right thing. The 3.3.6 server is being used. I have never had problems
with the 3.3.6 server and this card earlier.
Comment 5 Harshal Pradhan 2000-10-10 13:23:18 EDT
Yep, the server seems to be the problem .... 
Copied the /usr/X11R6/bin/XF86_SVGA binary over from another machine (debian
actually, I know I'm not supposed to do that :-) ) And all problems seem to have
gone away.
Also, bug 17991 seems to be a duplicate of this
Comment 6 Alan Cox 2000-10-14 18:46:50 EDT
Thanks for the info. That implies we picked up a patch along the way that broke
this card (and probably fixed something else in the process) or that we have a
build error. Glad to know the binary copy solved it for you.
Comment 7 Silvio 2000-10-19 13:59:30 EDT
I just want to add that I have the same problem... for the stats.... and
priority lists...
Comment 8 Richard Keech 2000-11-26 06:56:48 EST
I am also seeing this problem on machines with cards detected as Savage 3D.
Among the set of machines in use, some will not show any graphics mode 
video.  others show the chunky behavior described.  the cards with 1MB vram
give chunks.  the cards with 8MB vram crash and burn completely (Xconfigurator
fails to start the X server).  Different variations on the card type were
with no success.
Comment 9 Johnray Fuller 2000-12-13 13:36:20 EST
Please refer to the following link for a workaround for these cards:


Comment 10 Mike A. Harris 2001-02-28 02:00:13 EST
Fix for Savage should be ready soon if it checks out in our labs.

*** This bug has been marked as a duplicate of 17991 ***
Comment 11 Need Real Name 2001-10-09 08:32:02 EDT
I have the same problem, but I have not been able to solve it using any of the 
two methods specified in the gotchas-7-4.html#ss4.7

SuperProbe tells me I'm running the following card:

S3 ViRGE/GX (PCI Probed)
Memory: 2048
Ramdac: Generic 8-bit pseudo color DAC (with 6-bit wide lookup tables  (or in 6-
bit mode))

I'm a complete "newbie" in this Linuxworld, so I could indeed be doing 
something wrong.

Will it help upgrading from 7.0 -> 7.1???

Please help!

Note You need to log in before you can comment on or make changes to this bug.