Bug 17991 - Support for Savage 4 chipset is very poor
Support for Savage 4 chipset is very poor
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
: 16839 18587 18731 19149 19184 19272 19354 21636 22571 23492 28526 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-01 00:33 EDT by Ricardo Cerqueira
Modified: 2008-05-01 11:37 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 16:18:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ricardo Cerqueira 2000-10-01 00:33:29 EDT
When trying to use XF86_SVGA from RH7 (XFree86-SVGA-3.3.6-33), with a board
based on Savage 4, the graphics become completely unusable. Pieces of the
display overlap whenever a window pops up or is moved. Downgrading to
XFree86-SVGA-3.3.6-20 from RH 6.2 solves this problem.
Comment 1 Need Real Name 2000-10-03 04:22:17 EDT
Similar problems occur with the "Cirrus Logic|GD 5436 [Alpine]" controller.
They are also fixed by the same workaround: reverting to the 6.2 X Server.
(Interestingly, XFree 4.0.1 is supposed to support this card as well, but
Xconfigurator defaults to using XF86_SVGA and doesn't provide an obvious
way to change this default. I tried changing the /etc/X11/X symlink to XFree86
and that did fix display quality problems, but would only use 640x480 as the
resolution -- probably if I fiddled with things, I might have got 1024x768, but
I opted for the easy choice of reverting to the old server).
Comment 2 Eilko Bronsema 2000-10-03 09:43:41 EDT
Getting the server from S3 solved for me the problems:

ftp://ftp.s3.com/pub/s3/desktop/395/395_xf86_1011.tar.gz

Comment 3 Ricardo Cerqueira 2000-10-03 13:46:20 EDT
Errr... What does do S3 server has to do with this? It's an XF3 server. And I
think it's older than RH 6.2's version (which, as I previously stated, solves
the problem, and has the advantage of being a fully RH compatible RPM)
Comment 4 Wouter Liefting 2000-10-06 09:52:28 EDT
Same. Graphics card based on S3 Savage 4 chipset w/ 16 Mb (IBM 300PL system). Even the graphical install is barely usable. Windows overlap, text 
is replicated several times on the screen, borders disappear etc. Card is detected & configured ok though.

After installation, X seems to come up correctly. However, when moving a kdeterm over the screen, the screen is messed up completely. Looks like a 
memory map problem in the graphics adapter.
Comment 5 Ricardo Cerqueira 2000-10-11 21:40:11 EDT
Yes, installation/configuration with my adapter was pretty smooth, too. RH7's
graphic installation, on the other hand, had the same problem. So I guess the
same XF86_SVGA is used for both the install and the distro. Something must have
changed since the previous release. Since it is the same XF version, I'm betting
it's a RedHat-made bug. Some patch, or something.
Comment 6 Alan Cox 2000-10-15 20:00:36 EDT
*** Bug 19149 has been marked as a duplicate of this bug. ***
Comment 7 Alan Cox 2000-10-16 19:47:50 EDT
*** Bug 19184 has been marked as a duplicate of this bug. ***
Comment 8 Lothain 2000-10-19 22:42:14 EDT
I have a Diamond Stealth III S540 (S3 savage 4).......i downgraded Xfree86 fro 
3.3.6-33 (RH7) to 3.3.6-20 (RH6.2) this has seemed to fix the problem execpt i 
have a 1in square box for a mouse cursor......which can get really anoiying.
Comment 9 Panic 2000-10-25 14:43:10 EDT
You can add the Savage2000 to the list of affected cards.

Matt
Comment 10 Mike A. Harris 2000-12-05 03:17:23 EST
If I'm not mistaken (and I could be) S3 has recalled the Savage
video cards.  Someone might want to check S3's site for replacement
instructions (assuming I am correct).  It doesn't seem like this series
of cards work very well at all.
Comment 11 Harshal Pradhan 2000-12-05 11:29:20 EST
I dont know about the Savage 2000 and other S3 cards, but as far as Savage 4
goes I've seen the 3.3.6 X server from Redhat 6.2 (and even those from Debian
2.2, Mandrake 7.2) work without any glitches at all. This particualar problem is
specific to Redhat 7. And it goes away when you downgrade your server. You dont
even have to touch the rest of the X packages. In this case at least S3, doesnt
seem to be at any fault at all.

BTW, Bug 18371 is a duplicate of this. 
Comment 12 Johnray Fuller 2000-12-13 13:36:03 EST
Please refer to the following link for a workaround for these cards:

http://www.redhat.com/support/docs/gotchas/7.0/gotchas-7-4.html#ss4.7

Johnray
Comment 13 Bernhard Rosenkraenzer 2000-12-30 13:15:24 EST
*** Bug 21636 has been marked as a duplicate of this bug. ***
Comment 14 Mike A. Harris 2001-02-28 01:24:55 EST
*** Bug 22571 has been marked as a duplicate of this bug. ***
Comment 15 Mike A. Harris 2001-02-28 01:29:00 EST
*** Bug 19272 has been marked as a duplicate of this bug. ***
Comment 16 Mike A. Harris 2001-02-28 01:32:30 EST
*** Bug 23492 has been marked as a duplicate of this bug. ***
Comment 17 Mike A. Harris 2001-02-28 01:34:59 EST
*** Bug 28526 has been marked as a duplicate of this bug. ***
Comment 18 Mike A. Harris 2001-02-28 01:39:01 EST
*** Bug 19354 has been marked as a duplicate of this bug. ***
Comment 19 Mike A. Harris 2001-02-28 01:57:31 EST
*** Bug 16839 has been marked as a duplicate of this bug. ***
Comment 20 Mike A. Harris 2001-02-28 02:00:08 EST
*** Bug 18731 has been marked as a duplicate of this bug. ***
Comment 21 Mike A. Harris 2001-03-01 16:18:55 EST
*** Bug 18587 has been marked as a duplicate of this bug. ***
Comment 22 Mike A. Harris 2001-03-10 01:17:29 EST
The Savage driver has been updated in the latest release and fixes all
known issues I believe.  Please try the newest XFree86 package out
and it should fix the problems you're experiencing. Make sure you
grab the updated Mesa package as well so that 3D works properly:

ftp://people.redhat.com/mharris/xfree86
ftp://people.redhat.com/mharris/Mesa
Comment 23 Need Real Name 2001-04-14 14:18:27 EDT
I downloaded and installed the referenced RPMs:

ftp://people.redhat.com/mharris/xfree86
ftp://people.redhat.com/mharris/Mesa

Then re-ran Xconfigurator and there seems to be no change in symptoms. Am I 
missing something here?
Comment 24 Mike A. Harris 2001-04-14 20:33:34 EDT
Most likely you're still using XFree86 3.x
Run Xconfigurator with:

Xconfigurator --preferxf4

The configuration file for it is /etc/X11/XF86Config-4
*NOT* the XF86Config one - which is for XFree86 3.3.x.  If in doubt,
examining your X server logs should show which version you are running.
The new XFree86-4.0.3-9 release has made another change to the savage
driver as well, which should fix some more problems.
Comment 25 Need Real Name 2001-04-15 05:48:51 EDT
Thanks... I'll give it a go. Is the new XFree86-4.0.3-9 release available as an 
RPM?
Comment 26 Need Real Name 2001-04-15 08:36:55 EDT
OK, i tried Xconfigurator --preferxf4
There's still no change in symptoms. The file /etc/X11/XF86Config-4 doesn't 
exist either (before or after running Xconfigurator --preferxf4).
Any other ideas?
Thanks
Comment 27 Need Real Name 2001-05-11 04:37:15 EDT
I am using RH7.1 on a micron laptop with the S3 SAVAGE (generic).  The only 
corruption I experienced was in the mouse pointer which was a completely white 
square.  I tried manually applying the work-arounds, but eventually had to 
reinstall in order to get X to think I had a generic SVGA card.  I'm sure there 
is a better way to fix the problem, but it's not listed on RH's site.
Comment 28 Mike A. Harris 2001-10-09 08:45:40 EDT
This bug is marked CLOSED RAWHIDE, which means that this bug is fixed
in the RAWHIDE XFree86.  XFree86 4.1.0-3 is what you need.  You will
need to upgrade to Red Hat Linux 7.1 in order to use XFree86 4.1.0
with minimal hassle.  I suggest waiting for the release of Red Hat
Linux 7.2 however, and upgrade to that.

If you have questions or problems with either, please use our mailing
list support forums.  Good luck.

Note You need to log in before you can comment on or make changes to this bug.