This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 187339 - internal compiler error: in dwarf2out_finish, at dwarf2out.c:14116
internal compiler error: in dwarf2out_finish, at dwarf2out.c:14116
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gcc4 (Show other bugs)
5
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jakub Jelinek
:
: 190955 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-30 03:27 EST by KISHIMOTO, Makoto
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-06 09:37:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 27058 None None None Never

  None (edit)
Description KISHIMOTO, Makoto 2006-03-30 03:27:24 EST
Description of problem:
An internal compiler error occures in compiling.

Version-Release number of selected component (if applicable):
4.1.0-3

How reproducible:
Always

Steps to Reproduce:
$ cat foo.c
int
foo(void)
{
   if (sizeof(long) == 8) {
      typedef union {
         long i;
         char c[8];
      } comm;
      comm static volatile u;
      u.i = 0x01020304;
      u.i <<= 16, u.i <<= 16;
      u.i |= 0x05060708;
      return u.c[0] == 0x01 && u.c[1] == 0x02;
   }
   return 2;
}
$ gcc -O0 -g -c foo.c

Actual results:
foo.c:16: internal compiler error: in dwarf2out_finish, at dwarf2out.c:14116
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/cc??????.out file, please attach this to
your bugreport.

Expected results:
Compilation should be finish successful.

Additional info:
By omit "-g" or change "-O0" to "-O1", we can get around this error.
Comment 1 KISHIMOTO, Makoto 2006-03-30 18:19:53 EST
The code is minimal fragment to reproduce the problem in SpiderMonkey.
(
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/js/src/jscpucfg.c&rev=3.25#255 )
When compile this, with options "-O0 -g -c", cause the error.
Comment 2 Jakub Jelinek 2006-04-06 09:37:22 EDT
Tracking upstream.
Comment 3 Jakub Jelinek 2006-05-09 04:27:59 EDT
*** Bug 190955 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.