Bug 190955 - ICE for GCC: dwarf2out_finish, at dwarf2out.c:14116
ICE for GCC: dwarf2out_finish, at dwarf2out.c:14116
Status: CLOSED DUPLICATE of bug 187339
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-07 04:06 EDT by Igor Bukanov
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-09 04:27:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source that craches /usr/libexec/gcc/i386-redhat-linux/4.1.0/cc1 (42.12 KB, text/plain)
2006-05-07 04:06 EDT, Igor Bukanov
no flags Details

  None (edit)
Description Igor Bukanov 2006-05-07 04:06:44 EDT
Description of problem:

GCC crashes when compiling a C source from SpiderMonkey CVS HEAD, which is a JS
engine for Mozilla browsers.

Version-Release number of selected component (if applicable):
gcc (GCC) 4.1.0 20060304 (Red Hat 4.1.0-3)

How reproducible:

Run the attched preprocessed source against
/usr/libexec/gcc/i386-redhat-linux/4.1.0/cc1:

/usr/libexec/gcc/i386-redhat-linux/4.1.0/cc1 -quiet -ILinux_All_DBG.OBJ
-DGCC_OPT_BUG -DXP_UNIX -DSVR4 -DSYSV -D_BSD_SOURCE -DPOSIX_SOURCE
-DHAVE_LOCALTIME_R -DX86_LINUX -DDEBUG -DDEBUG_igor -DEDITLINE -DJS_VERSION=150
jscpucfg.i -quiet -dumpbase jscpucfg.c -mtune=generic -auxbase-strip jscpucfg.i
-g -Wall -Wno-format -o - -frandom-seed=0



Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Igor Bukanov 2006-05-07 04:06:44 EDT
Created attachment 128701 [details]
Preprocessed source that craches /usr/libexec/gcc/i386-redhat-linux/4.1.0/cc1
Comment 2 Igor Bukanov 2006-05-07 04:37:19 EDT
Here is a minimal test case to trigger the bug:

int main()
{
    if (sizeof(long) == 8) {

        volatile static union {
            long i;
            char c[8];
        } u;

        u.i = 0;
        return (u.c[0] == 0x01 && u.c[1] == 0x02);
    }

    return 0;
}


Save it as test.c or test.i and try on FC5 for x86:

gcc -c -g test.c
gcc -c -g test.i
/usr/libexec/gcc/i386-redhat-linux/4.1.0/cc1 test.i  -g

In all cases the result is:
test.i:15: internal compiler error: in dwarf2out_finish, at dwarf2out.c:14116

If I remove -g, then there is no error (kind of obvious given the source bug)
Comment 3 Jakub Jelinek 2006-05-09 04:27:37 EDT

*** This bug has been marked as a duplicate of 187339 ***

Note You need to log in before you can comment on or make changes to this bug.