Bug 1873487 - GET on asynchronous operation task monitor returns HTTP '202 Accepted' status code without 'Location' header
Summary: GET on asynchronous operation task monitor returns HTTP '202 Accepted' status...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Bare Metal Hardware Provisioning
Version: 4.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Derek Higgins
QA Contact: Amit Ugol
URL:
Whiteboard:
: 1874238 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-28 13:45 UTC by Derek Higgins
Modified: 2020-10-27 16:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: sushy-oem-idrac required a 'Location:' header for asynchronous operations Consequence: during virtual media boot ironic failed to set the boot device on some idrac based hardware Fix: sushy-oem-idrac patched with a fix Result: ironic can now set the boot device
Clone Of:
Environment:
Last Closed: 2020-10-27 16:35:38 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 726275 0 None MERGED Fix GET HTTP 202 status without Location 2021-02-17 12:57:36 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:35:55 UTC

Description Derek Higgins 2020-08-28 13:45:56 UTC
iDrac virtual media install fails on Some hardware (Observed on a Dell 640 with firmware version 4.20.20.20 and possibly 3.34.34.34 )

This results in master nodes failing to provision when using vmedia, with

2020-08-27 13:27:05.862 1 DEBUG ironic.drivers.modules.drac.boot [req-e98c89cd-bfb3-4ee9-9e24-4473d72263a1 - - - - -] Sushy OEM extension Python package 'sushy-oem-idrac' failed to set virtual boot device with system 4c4c4544-0048-3710-8050-b3c04f505832 manager 3258504f-c0b3-5080-3710-00484c4c4544 for node 458cd6f7-f6a0-45ce-88a0-2b3bf2038a3c. Will try next manager, if available. Error: Sushy Extension Error: Response 202 to HTTP POST with args ('/redfish/v1/Managers/iDRAC.Embedded.1/Actions/Oem/EID_674_Manager.ImportSystemConfiguration',), kwargs {'data': {'ShareParameters': {'Target': 'ALL'}, 'ImportBuffer': '<SystemConfiguration><Component FQDD="iDRAC.Embedded.1"><Attribute Name="ServerBoot.1#BootOnce">Enabled</Attribute><Attribute Name="ServerBoot.1#FirstBootDevice">VCD-DVD</Attribute></Component></SystemConfiguration>'}} does not include Location: in header _set_boot_device /usr/lib/python3.6/site-packages/ironic/drivers/modules/drac/boot.py:144^[[00m


Details copied from https://storyboard.openstack.org/#!/story/2007640

When a GET request is performed on an asynchronous operation task monitor URI, the iDRAC service can return the HTTP 202 Accepted status code without a Location header. This has been observed with at least iDRAC firmware versions 3.30.30.30 and 4.10.10.10 for 14th generation hardware (14G) when issuing a request for the long-running OEM Server Configuration Profile (SCP) import and export system configuration operations. [1] sushy-oem-idrac requires the Location header to continue to query the status of the operation, and determine when it has completed and whether it succeeded.

Comment 1 Derek Higgins 2020-08-28 13:47:53 UTC
Attaching upstream sushy-oem-idrac patch

Comment 3 Beth White 2020-09-01 16:35:19 UTC
*** Bug 1874238 has been marked as a duplicate of this bug. ***

Comment 4 Derek Higgins 2020-09-14 11:09:46 UTC
The upstream patch for this hasn't moved for some time, I'll bring it up in the upcoming upstream meeting to try and get things moving

Comment 5 Bob Fournier 2020-09-23 13:17:50 UTC
Patch has been merged and python-sushy-oem-idrac-0.0.3-0.20200922221223.1202372.el8ost has been tagged for 4.6 per https://bugzilla.redhat.com/show_bug.cgi?id=1881943.

Comment 7 rlopez 2020-09-29 13:10:06 UTC
Confirmed that 4.6.0-0.nightly-2020-09-28-061045 has the fix for this issue.

Comment 8 Derek Higgins 2020-09-29 13:36:05 UTC
marking as VERIFIED as tested by rlopez

Comment 11 errata-xmlrpc 2020-10-27 16:35:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.