This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 187411 - ..MP-BIOS bug: 8254 timer not connected to IO-APIC
..MP-BIOS bug: 8254 timer not connected to IO-APIC
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-30 14:29 EST by draconishinobi
Modified: 2015-01-04 17:26 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-17 01:38:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg (16.76 KB, application/octet-stream)
2006-04-04 09:28 EDT, John Boyd
no flags Details
dmesg with acpi-off specified in grub (12.83 KB, application/octet-stream)
2006-04-04 09:30 EDT, John Boyd
no flags Details
cat /proc/interrupts showing timer mismatch (721 bytes, application/octet-stream)
2006-04-04 09:32 EDT, John Boyd
no flags Details
computer setup (13.36 KB, application/octet-stream)
2006-04-04 09:33 EDT, John Boyd
no flags Details
text file specifications (11.13 KB, application/octet-stream)
2006-04-04 17:44 EDT, draconishinobi
no flags Details
running buggy kernel with noapic flag (18.96 KB, application/octet-stream)
2006-04-07 17:53 EDT, draconishinobi
no flags Details
dmesg output (15.27 KB, text/plain)
2006-05-10 00:52 EDT, petrosyan
no flags Details
dmesg output (15.46 KB, text/plain)
2006-09-21 13:48 EDT, petrosyan
no flags Details
dmesg output (15.20 KB, text/plain)
2006-10-16 23:49 EDT, petrosyan
no flags Details

  None (edit)
Description draconishinobi 2006-03-30 14:29:16 EST
Description of problem:

When I boot kernel-2.6.16-1.2069_FC4-i686 after it says uncompressing and
booting it gives me the following error line:

..MP-BIOS bug: 8254 timer not connected to IO-APIC

This only happens in the new kernel-2.6.16-1.2069_FC4-i686, as well as in all
Fedora Core 5 kernels. It does NOT happen in kernel-2.6.15-1.1833_FC4-i686 or
any previous kernel. It does not seem to affect funtionality of the Fedora Core,
but I'd still like to know what it means, and why it happens in every kernel
realeased after kernel-2.6.15-1.1833_FC4-i686 ? And if there's a way to fix it.

Version-Release number of selected component (if applicable):

Problem with kernel-2.6.16-1.2069_FC4-i686 and FC5 kernels

How reproducible:

Just boot computer.

Steps to Reproduce:
1. Install new kernel
2. Boot new kernel
3.
  
Actual results:


Expected results:


Additional info:

I was using Fedora Core 5 for a while and then reverted to FC4 just to see if
the bug would dissapear, it did but reappeared with the new
kernel-2.6.16-1.2069_FC4-i686

Computer Specs if you need them:
It's a laptop
2.8 Ghz Pentium 4
SiS chipset and motherboard
1 GB DDR SDRAM
nVidia GeForce 4 420 Go
Comment 1 John Boyd 2006-04-04 09:26:07 EDT
Hello,

I also have the exact problem (..MP-BIOS bug: 8254 timer not connected to IO-APIC
)running FC5 on an hp laptop. Previously I did not see this message while
running FC4. I tried acpi=off while the message disappeared but I got.....

atiixp: codec read timeout (reg 0)
atiixp: codec read timeout (reg 1c)

happening multiple times when I ran dmesg.see attachment3 [details]-dmesg-acpi-off.

I have attached some dmesg outputs and also a "cat /proc/interrupts" output
showing clock slightly off.

hope this info helps,
Comment 2 John Boyd 2006-04-04 09:28:37 EDT
Created attachment 127291 [details]
dmesg
Comment 3 John Boyd 2006-04-04 09:30:31 EDT
Created attachment 127293 [details]
dmesg with acpi-off specified in grub
Comment 4 John Boyd 2006-04-04 09:32:22 EDT
Created attachment 127294 [details]
cat /proc/interrupts showing timer mismatch
Comment 5 John Boyd 2006-04-04 09:33:57 EDT
Created attachment 127296 [details]
computer setup
Comment 6 draconishinobi 2006-04-04 17:44:31 EDT
Created attachment 127315 [details]
text file specifications

output of lspci -vv and cat /proc/interrupts while running the non-buggy
kernel-2.6.15-1.1833_FC4-i686

Should I try to get demsg by running the newer kernel and turning off acpi ?
Just to see if I get similar results ?
Comment 7 draconishinobi 2006-04-07 17:53:31 EDT
Created attachment 127485 [details]
running buggy kernel with noapic flag

This is the output of dmesg and cat /proc/interrupts when booting
kernel-2.6.16-1.2069_FC4-i686 with noapic flag

Everything seems to work ok with this setting.
Comment 8 draconishinobi 2006-04-07 17:56:13 EDT
Comment on attachment 127485 [details]
running buggy kernel with noapic flag

This is the output of dmesg and cat /proc/interrupts when booting
kernel-2.6.16-1.2069_FC4-i686 with noapic flag

Everything seems to work ok with this setting ... no more ..MP-BIOS bug warning
when booting.
Comment 9 Konrad Rzeszutek 2006-04-07 20:48:21 EDT
Do those boxes have updated BIOSes? Having to use noapic usually means buggy
BIOS/legacy hardware.

Could you say which HP laptop it is exactly? Model and BIOS version would help.
Comment 10 John Boyd 2006-04-07 23:20:17 EDT
Hello ,

Laptop specs,

HP Pavilion ZV5346us
ROMPag BIOS (up to date) F.45
512 mb ram (128 mb shared with ATi 9100IGP video card.
FC5 kernel-smp-2.6.16-1.2080_FC5.i686.

My dmesg attachments seems to indicate a problem when ATI board is detected. I
also noticed that cpuspeed no longer works.

I am reinstalling FC4 at the moment to see if I will have the same problem. I
had FC4 on before I upgraded and did not have the MP-BIOS bug problem.
Comment 11 John Boyd 2006-04-07 23:32:52 EDT
restarted laptop with noapic flag (FC5 configuration above) MP-BIOS message
disappeared but got the following message :

Starting udev : disabling IRQ 5.

then machine froze at:

Starting bluetooth services [ok].

I had to use the power button to shut down machine.
Comment 12 draconishinobi 2006-04-09 16:54:59 EDT
A similar thing happened to me ... and it froze on bluetooth as well. I was able
to Ctrl-Alt-F1 and change the grub.config accordingly. But it's strange that it
didn't happen the first time I used the noapic flag, only the second time.

My laptop is a Sony Vaio PCG-GRT100
BIOS Phoenix WinPhlash for VAIO

My BIOS was updated about 2 years ago ... however, it seems there is no newer
update. This is the only update released, and I updated to it 2 years ago:
http://esupport.sony.com/perl/swu-download.pl?mdl=PCGGRT100&upd_id=1412&os_id=7
Comment 13 James 2006-04-12 06:39:39 EDT
I've an HP zx5030EA (ATI chipset, F.43 BIOS) and I see this message. I've only
ever seen it with FC5; never with FC3. As far as I'm aware, there's been no ill
effect and all the interrupts are going through the IO-APIC and LAPIC OK (under
FC3, I had to boot an SMP kernel to get IO-APIC support otherwise the IRQ
routing would've been a mess).

dmesg log includes:

ENABLING IO-APIC IRQs
..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
..MP-BIOS bug: 8254 timer not connected to IO-APIC
...trying to set up timer (IRQ0) through the 8259A ...  failed.
...trying to set up timer as Virtual Wire IRQ... works.

Does this machine even have an i8254? Doesn't the LAPIC supercede this chip?
Typical /proc/interrupts reads:

           CPU0
  0:     972673  local-APIC-edge  timer
  1:       3093    IO-APIC-edge  i8042
  5:     156268   IO-APIC-level  ATI IXP, ATI IXP Modem
  7:          2    IO-APIC-edge  parport0
  8:          1    IO-APIC-edge  rtc
 12:        144    IO-APIC-edge  i8042
 14:      31112    IO-APIC-edge  ide0
 15:      34022    IO-APIC-edge  ide1
 16:          1   IO-APIC-level  yenta
 17:     347478   IO-APIC-level  yenta, ohci_hcd:usb3, ohci1394,
radeon@pci:0000:01:05.0
 18:      95925   IO-APIC-level  ohci_hcd:usb1, ohci_hcd:usb2, ehci_hcd:usb5, eth0
 19:         49   IO-APIC-level  ohci_hcd:usb4
 21:      14027   IO-APIC-level  acpi
NMI:          0
LOC:     972592
ERR:          0
MIS:          0
Comment 14 myy.email 2006-04-19 04:05:45 EDT
The same error but a bit different story.

At first everything worked fine (2.6.15-1.2054_FC5). Both x86 and x86_64
kernels. I tried both version to see which one works better. Finnaly I've opted
for x86. I have AMD64 MSI RS480 chipset machine.

I have a dual-boot computer (Linux and Windows). Once I restarted computer from
within Windows and when Linux was going up I received this error:

MP-BIOS bug: 8254 timer not connected to IO-APIC

I suspected that something went wrong with installatin first and tried to
reinstall it but strangely enough I was not able to do this also. The setup get
stuck in some moment. It just freezes.


Comment 15 petrosyan 2006-05-07 19:47:11 EDT
This bug also happens with kernel-2.6.16-1.2111_FC5 on
Toshiba Satellite L25-S1192

I just updated the BIOS to the latest version (April 2006 version) and the bug
is still there.
Comment 16 Konrad Rzeszutek 2006-05-09 14:17:59 EDT
Ani,

Could you try using the SMP kernel?
Comment 17 petrosyan 2006-05-10 00:51:19 EDT
this still happens with SMP kernel. Attaching the dmesg output.
Comment 18 petrosyan 2006-05-10 00:52:16 EDT
Created attachment 128832 [details]
dmesg output
Comment 20 draconishinobi 2006-05-22 20:03:41 EDT
I am now pretty sure that the BIOS is to blame. The newer kernels fixed a
different problem on my desktop computer (the system time running twice normal
speed on SMP kernel), but broke support for BIOS on my notebook. My notebook
won't even boot on kernels newer than 2.6.15-1.2054_FC5. The problem is that you
don't exactly know what the BIOS update fixes and what it doesn't.
Comment 21 petrosyan 2006-06-25 08:34:32 EDT
this bug still happens with kernel-2.6.17-1.2139_FC5

Checking 'hlt' instruction... OK.
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
..MP-BIOS bug: 8254 timer not connected to IO-APIC
...trying to set up timer (IRQ0) through the 8259A ...  failed.
...trying to set up timer as Virtual Wire IRQ... works.
checking if image is initramfs... it is
Comment 22 draconishinobi 2006-07-22 22:56:19 EDT
upon looking at this wiki, you might wanna try

noapic nolapic

as kernel boot parameters
from: http://en.wikipedia.org/wiki/IO-APIC

I haven't tested if this extra nolapic helps any ... I will when I can
Comment 23 Dan Carpenter 2006-07-23 15:44:20 EDT
On many nvidia based chipsets the system will occasionally lock up on boot with
those messages unless you use "acpi_skip_timer_override=1".  It's worth a shot.

> noapic nolapic

Those are always a useful tool for debugging problems but I wouldn't use them in
production settings.
Comment 24 draconishinobi 2006-07-23 21:19:37 EDT
yeah, don't use nolapic ... the system clock goes mad if you do

Well, I've been looking at the kernel sources recently tring to see what goes
wrong. It looks like the error is generated within a function in
linux-2.6.1.x/arch/i386/kernel/io_apic.c called check_timer. The error only gets
printed if pin1 is anything but -1 and the function timer_irq_works returns zero
indicating that the timer IRQs are "defunct". There is a comment about this
function:

There is a nasty bug in some older SMP boards, their mptable lies
about the timer IRQ. We do the following to work around the situation:

- timer IRQ defaults to IO-APIC IRQ
- if this function detects that timer IRQs are defunct, then we fall
back to ISA timer IRQs

I think this shouldn't happen because I don't have an older SMP board ...
Comment 25 draconishinobi 2006-07-24 00:45:41 EDT
Well it looks like adding the boot flags 'noapic noioapic' is the easiest
option, you don't really need ioapic unless you run an smp kernel anyway, which
I don't so turning it off will have no effect (hopefully) ... I think it may
interfere with SELinux in some negative way, or maybe the events were unrelated.
The crash I had in the past while using the noapic flag may have been due to
SELinux not the noapic flag.
Comment 26 Dave Jones 2006-09-16 23:13:22 EDT
[This comment added as part of a mass-update to all open FC4 kernel bugs]

FC4 has now transitioned to the Fedora legacy project, which will continue to
release security related updates for the kernel.  As this bug is not security
related, it is unlikely to be fixed in an update for FC4, and has been migrated
to FC5.

Please retest with Fedora Core 5.

Thank you.
Comment 27 petrosyan 2006-09-21 13:48:24 EDT
Created attachment 136895 [details]
dmesg output
Comment 28 petrosyan 2006-09-21 13:49:51 EDT
This bug still happens on Fedora Core 5 kernel-2.6.17-1.2187_FC5.
Look at the attached dmesg output for details.
Comment 29 John Boyd 2006-09-21 18:41:32 EDT
Another thing I noticed is that cpuinfo indicates 'stepping 9'
yet I only get 3 cpufrequency steps from 2.10 Ghz to 2.8 Ghz. This only started
happening after kernel-2.6.15-1.1833_FC4-i686 and also when these error messages
started showing up, and it continues through to FC5. It should be noted that I
tried opensuse 10.1 and it also happens .
 
Comment 30 Dave Jones 2006-10-16 20:24:26 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 31 petrosyan 2006-10-16 23:46:26 EDT
This bug still happens in 2.6.18-1.2200.fc5
attaching the dmesg output.
Comment 32 petrosyan 2006-10-16 23:49:30 EDT
Created attachment 138652 [details]
dmesg output
Comment 33 Dave Jones 2006-10-17 01:38:27 EDT
As the message suggests, these messages are indicative of a problem with the way
the BIOS has set up IRQ routing.  In the majority of cases, as also noted above,
 it doesn't seem to affect anything.   If this is actually causing problems, I
suggest filing a bug in the upstream kernel bugzilla at http://bugme.osdl.org
where upstream maintainers with APIC know how will be more likely to respond.

Note You need to log in before you can comment on or make changes to this bug.