Bug 1875180 - [4.5] crio configuration changes unexpectedly when ctrcfg is applied
Summary: [4.5] crio configuration changes unexpectedly when ctrcfg is applied
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.z
Assignee: Peter Hunt
QA Contact: Sunil Choudhary
URL:
Whiteboard:
Depends On: 1875179
Blocks: 1875181
TreeView+ depends on / blocked
 
Reported: 2020-09-02 23:58 UTC by Peter Hunt
Modified: 2020-09-14 14:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1875179
: 1875181 (view as bug list)
Environment:
Last Closed: 2020-09-14 14:54:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:3618 0 None None None 2020-09-14 14:54:48 UTC

Description Peter Hunt 2020-09-02 23:58:01 UTC
+++ This bug was initially created as a clone of Bug #1875179 +++

Description of problem:
when a ctrcfg is applied, the resulting configuration has unintended changes. The most notable is the value of `default_env` becomes empty. The others (all containers/storage parameters) can be empty, because of the way crio mixes crio.conf and storage.conf. However, the default_env being empty can cause regressions in nss db.

Version-Release number of selected component (if applicable):
4.4 and 4.3

How reproducible:


Steps to Reproduce:
1. run `crio config` on a node
2. apply any ctrcfg
3. run `crio config` on a node, and observe the difference

Actual results:
the field
```
    default_env = [
        "NSS_SDB_USE_CACHE=no",
    ]
```
is now
```
    default_env = [
    ]
```
Expected results:
default_env should not have been emptied

Additional info:

--- Additional comment from Peter Hunt on 2020-09-02 23:57:15 UTC ---

This comes from the vendored version of cri-o becoming out of sync with the version of cri-o in openshift. When we make a change in the configuration values, we need to update the vendor.

From my testing, this is no longer the case in 4.6, as it has a vendored version of cri-o that contains default_env

Comment 1 Peter Hunt 2020-09-02 23:58:42 UTC
this is also fixed in 4.5 for the same reason as above

Comment 9 errata-xmlrpc 2020-09-14 14:54:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.9 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3618


Note You need to log in before you can comment on or make changes to this bug.