Bug 1876012 - File conflict between mariadb-devel & mariadb-connector-c-devel ( /usr/include/mysql/mariadb_rpl.h )
Summary: File conflict between mariadb-devel & mariadb-connector-c-devel ( /usr/includ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mariadb
Version: 31
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Schorm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1876201
TreeView+ depends on / blocked
 
Reported: 2020-09-04 21:43 UTC by Miro Hrončok
Modified: 2020-09-29 06:57 UTC (History)
11 users (show)

Fixed In Version: mariadb-10.3.22-3.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-10 17:34:23 UTC
Type: Bug


Attachments (Terms of Use)

Description Miro Hrončok 2020-09-04 21:43:33 UTC
Description of problem:
After this update https://bodhi.fedoraproject.org/updates/FEDORA-2020-0118297cba the package mariadb-connector-c-devel has an implicit file conflict with mariadb-devel.



$ rpm -q mariadb-connector-c-devel
mariadb-connector-c-devel-3.1.7-1.fc31.x86_64

$ rpm -q mariadb-devel
mariadb-devel-10.3.22-1.fc31.x86_64

$ sudo dnf update
...
Error: Transaction test error:
  file /usr/include/mysql/mariadb_rpl.h from install of mariadb-connector-c-devel-3.1.9-5.fc31.x86_64 conflicts with file from package mariadb-devel-3:10.3.22-1.fc31.x86_64



Version-Release number of selected component: 3.1.9-5.fc31


How reproducible: easy

Steps to Reproduce:
1. install mariadb-connector-c-devel and mariadb-devel at the same time

Actual results:
installation not possible due to file conflict

Expected results:
installation possible without file conflicts

Comment 1 Michal Schorm 2020-09-05 00:25:52 UTC
Thanks for the report.

I tested it on F32+ too, but the issue isn't present there.
It is present only on F31 with the current version MariaDB 10.3.

An update for MariaDB 10.3 is planned.
It will either be solved by upstream, or I'll fix it manually as a part of the update.

Comment 2 Lukas Javorsky 2020-09-07 08:55:35 UTC
Duplicate of BZ#1839428

I'm working on it

Comment 3 Lukas Javorsky 2020-09-07 09:05:41 UTC
Sorry for previous comment. I've decided that it's better to track it here.

BZ#1839428 was for rawhide, so I don't want to mix them

New release is building, and I'll add tracking for the fedora update system here

Comment 4 Fedora Update System 2020-09-07 11:20:59 UTC
FEDORA-2020-3868184fd2 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-3868184fd2

Comment 5 Fedora Update System 2020-09-07 17:57:07 UTC
FEDORA-2020-3868184fd2 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-3868184fd2`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-3868184fd2

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2020-09-10 17:34:23 UTC
FEDORA-2020-3868184fd2 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 7 Roger Wells 2020-09-21 13:20:07 UTC
This is still happening, or so it seems:
# dnf update

at the end yields:

Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction test error:
  file /etc/my.cnf from install of MariaDB-common-10.4.14-1.fc31.x86_64 conflicts with file from package mariadb-connector-c-config-3.1.9-5.fc32.noarch
  file /usr/bin/mariadb_config from install of MariaDB-devel-10.4.14-1.fc31.x86_64 conflicts with file from package mariadb-connector-c-devel-3.1.9-5.fc32.x86_64
  file /usr/bin/mysql_config from install of MariaDB-devel-10.4.14-1.fc31.x86_64 conflicts with file from package mariadb-connector-c-devel-3.1.9-5.fc32.x86_64
  file /usr/include/mysql/mariadb_version.h from install of MariaDB-devel-10.4.14-1.fc31.x86_64 conflicts with file from package mariadb-connector-c-devel-3.1.9-5.fc32.x86_64
  file /usr/include/mysql/mysql_version.h from install of MariaDB-devel-10.4.14-1.fc31.x86_64 conflicts with file from package mariadb-connector-c-devel-3.1.9-5.fc32.x86_64
  file /usr/include/mysql/mysqld_error.h from install of MariaDB-devel-10.4.14-1.fc31.x86_64 conflicts with file from package mariadb-connector-c-devel-3.1.9-5.fc32.x86_64

Comment 8 Lukas Javorsky 2020-09-22 08:20:07 UTC
Hi Roger,

Could you please try to update your mariadb packages too? Because it looks like you have f31 packages on f32 operation system.

I've tried newest releases of mariadb (10.4.14-2) and mariadb-connector-c (3.1.9-5) on f32 and there is no conflict/error with that.

Thank you
Lukas

Comment 9 Roger Wells 2020-09-22 12:33:53 UTC
Thanks Lukas,
The problem we are addressing here has prevented me from updating.
So I did this:
    dnf erase mariadb-devel
This also removed mariadb-connector-c.
I was then able to do
    dnf update
Now all mariadb packages are F32
However,
    dnf install mariadb-devel 
fails with the file conflicts regarding /usr/include/mysql/mariadb_rpl.h

Comment 10 Lukas Javorsky 2020-09-23 07:32:31 UTC
Hmmm, it's interesting.

I've just tried to install all three of them (mariadb, mariadb-devel, mariadb-connector-c) on a clear f32 machine and it passed with no issue.

Could you please run this command for me and paste the result here: rpm -qa 'mariadb*'

And after that please run the 'dnf update' command and paste the last section (the one that complains about this conflict we are discussing) here?

Thank you
Lukas

Comment 11 Roger Wells 2020-09-23 12:47:35 UTC
Lukas,
here it is:

rpm -qa 'mariadb*'
mariadb-server-utils-10.4.14-2.fc32.x86_64
mariadb-backup-10.4.14-2.fc32.x86_64
mariadb-connector-c-config-3.1.9-5.fc32.noarch
mariadb-common-10.4.14-2.fc32.x86_64
mariadb-gssapi-server-10.4.14-2.fc32.x86_64
mariadb-10.4.14-2.fc32.x86_64
mariadb-server-10.4.14-2.fc32.x86_64
mariadb-errmsg-10.4.14-2.fc32.x86_64
mariadb-cracklib-password-check-10.4.14-2.fc32.x86_64
mariadb-connector-c-3.1.9-5.fc32.x86_64

and

(I've included the entire output because it appears that even though f32 stuff is installed it is going to install some f31 equivalents)

[roger@rwells-x280 test]$ sudo dnf update --best --allowerasing
Last metadata expiration check: 0:01:40 ago on Wed 23 Sep 2020 08:07:51 AM EDT.
Dependencies resolved.
=========================================================================================================================================================================
 Package                                                 Architecture                   Version                                   Repository                        Size
=========================================================================================================================================================================
Installing dependencies:
 MariaDB-client                                          x86_64                         10.4.14-1.fc31                            mariadb                          7.6 M
     replacing  mariadb.x86_64 3:10.4.14-2.fc32
 MariaDB-common                                          x86_64                         10.4.14-1.fc31                            mariadb                           88 k
 MariaDB-server                                          x86_64                         10.4.14-1.fc31                            mariadb                           17 M
     replacing  mariadb-server.x86_64 3:10.4.14-2.fc32
 boost-program-options                                   x86_64                         1.69.0-18.fc32                            updates                          160 k
 galera-4                                                x86_64                         26.4.5-1.fc31                             mariadb                           14 M
 socat                                                   x86_64                         1.7.3.4-2.fc32                            fedora                           304 k
Removing dependent packages:
 mariadb-backup                                          x86_64                         3:10.4.14-2.fc32                          @updates                          26 M
 mariadb-cracklib-password-check                         x86_64                         3:10.4.14-2.fc32                          @updates                          16 k
 mariadb-gssapi-server                                   x86_64                         3:10.4.14-2.fc32                          @updates                          21 k
 mariadb-server-utils                                    x86_64                         3:10.4.14-2.fc32                          @updates                         7.3 M

Transaction Summary
=========================================================================================================================================================================
Install  6 Packages
Remove   4 Packages

Total download size: 39 M
Is this ok [y/N]: y
Downloading Packages:
(1/6): socat-1.7.3.4-2.fc32.x86_64.rpm                                                                                                   762 kB/s | 304 kB     00:00    
(2/6): MariaDB-common-10.4.14-1.fc31.x86_64.rpm                                                                                          357 kB/s |  88 kB     00:00    
(3/6): boost-program-options-1.69.0-18.fc32.x86_64.rpm                                                                                    82 kB/s | 160 kB     00:01    
(4/6): MariaDB-client-10.4.14-1.fc31.x86_64.rpm                                                                                          1.0 MB/s | 7.6 MB     00:07    
(5/6): MariaDB-server-10.4.14-1.fc31.x86_64.rpm                                                                                          2.0 MB/s |  17 MB     00:08    
(6/6): galera-4-26.4.5-1.fc31.x86_64.rpm                                                                                                 1.8 MB/s |  14 MB     00:07    
-------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                    3.6 MB/s |  39 MB     00:10     
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction test error:
  file /etc/my.cnf from install of MariaDB-common-10.4.14-1.fc31.x86_64 conflicts with file from package mariadb-connector-c-config-3.1.9-5.fc32.noarch

Comment 12 Miro Hrončok 2020-09-23 14:12:25 UTC
There is some kind of mariadb repo present that does not seem to originate in Fedora.

Comment 13 Lukas Javorsky 2020-09-24 06:51:39 UTC
Yes, Miro is right,

You have installed mariadb from 'mariadb' repo which is not fedora's and that is causing the problem.

You should use our fedora repos for mariadb and mariadb-connector-c to be sure everything works.

If it's possible please 'dnf remove' your current mariadb and maybe also remove the 'mariadb' repo or at least disable it during 'dnf install' by using '--disablerepo=mariadb' option.

Comment 14 Roger Wells 2020-09-24 12:49:52 UTC
I'll do it and let you know.
I have no idea how the mariadb repo got there

Comment 15 Lukas Javorsky 2020-09-25 12:42:24 UTC
Okay thank you, I'll wait for the response.

Comment 16 Roger Wells 2020-09-25 13:54:15 UTC
Sorry for the delay.
Yes, eliminating mariadb repository fixed it.
Now dnf update proceeds as expected and all mariadb related packages are F32
I have no idea how that repository was enabled in the first place but.....
Thanks for your help.

Comment 17 Lukas Javorsky 2020-09-29 06:57:27 UTC
You're welcome and thank you for your investigation.


Note You need to log in before you can comment on or make changes to this bug.