Bug 1876201 - Cannot update mariadb-connector-c since mariadb-devel package too old
Summary: Cannot update mariadb-connector-c since mariadb-devel package too old
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mariadb
Version: 31
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Michal Schorm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1876012
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-06 10:09 UTC by Quentin Armitage
Modified: 2020-09-11 03:50 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-11 03:50:40 UTC
Type: Bug


Attachments (Terms of Use)

Description Quentin Armitage 2020-09-06 10:09:55 UTC
1. Please describe the problem:
dnf upgrade fails with the message:
Error: Transaction test error:
  file /usr/include/mysql/mariadb_rpl.h from install of mariadb-connector-c-devel-3.1.9-5.fc31.x86_64 conflicts with file from package mariadb-devel-3:10.3.22-1.fc31.x86_64


2. Specify used package versions
# dnf list installed | grep -i -e maria -e mysql -e galera
mariadb.x86_64                                     3:10.3.22-1.fc31                       @updates        
mariadb-backup.x86_64                              3:10.3.22-1.fc31                       @updates        
mariadb-common.x86_64                              3:10.3.22-1.fc31                       @updates        
mariadb-connector-c.x86_64                         3.1.7-1.fc31                           @updates        
mariadb-connector-c-config.noarch                  3.1.7-1.fc31                           @updates        
mariadb-connector-c-devel.x86_64                   3.1.7-1.fc31                           @updates        
mariadb-cracklib-password-check.x86_64             3:10.3.22-1.fc31                       @updates        
mariadb-devel.x86_64                               3:10.3.22-1.fc31                       @updates        
mariadb-errmsg.x86_64                              3:10.3.22-1.fc31                       @updates        
mariadb-gssapi-server.x86_64                       3:10.3.22-1.fc31                       @updates        
mariadb-server.x86_64                              3:10.3.22-1.fc31                       @updates        
mariadb-server-utils.x86_64                        3:10.3.22-1.fc31                       @updates        
mysql-selinux.noarch                               1.0.0-8.fc30                           @fedora         
perl-DBD-MySQL.x86_64                              4.050-4.fc31                           @fedora         
php-mysqlnd.x86_64                                 7.3.21-1.fc31                          @updates  


3. Does a systemd journal say anything about the issue?
# journalctl -xe -u mariadb -u mysqld
No relevant messages


4. Please check and attach the MariaDB or MySQL server log?  ("/var/log/mariadb/mariadb.log" or "/var/log/mysql/mysqld.log")
N/A


5. Please check and paste your configuration here; remove sensitive information.
# /usr/libexec/mysqld --print-defaults
/usr/libexec/mysqld would have been started with the following arguments:
--datadir=/var/lib/mysql --socket=/var/lib/mysql/mysql.sock --log-error=/var/log/mariadb/mariadb.log --pid-file=/run/mariadb/mariadb.pid


5. Can you reproduce this issue? If so, please provide the steps to reproduce the issue below:
dnf upgrade

Do an updated version of mariadb need to be built for Fedora 31?

Comment 2 Lukas Javorsky 2020-09-07 08:55:53 UTC
Duplicate of BZ#1839428

I'm working on it

Comment 3 Lukas Javorsky 2020-09-07 09:09:34 UTC
The tracking will be in BZ#1876012

I apologize for the confusion

Comment 4 Michal Schorm 2020-09-11 03:50:40 UTC
Should be fixed by following update:
  https://bodhi.fedoraproject.org/updates/FEDORA-2020-3868184fd2

Feel free to re-open this BZ, if the issue persist


Note You need to log in before you can comment on or make changes to this bug.