Bug 187626 - FC5. anaconda crashesin ffset.py on floppy (/dev/fd0)
FC5. anaconda crashesin ffset.py on floppy (/dev/fd0)
Status: CLOSED DUPLICATE of bug 185853
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-01 19:54 EST by David Anderson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-04-03 15:05:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump written to floppy on anaconda crash. (251.38 KB, text/plain)
2006-04-01 19:54 EST, David Anderson
no flags Details

  None (edit)
Description David Anderson 2006-04-01 19:54:39 EST
Description of problem:
FC5. upgrade from FC4. Anaconda crashes  whether  floppy
inserted or not.


Version-Release number of selected component (if applicable):
FC5 released


How reproducible:
Reproduces every time.


Steps to Reproduce:
1. Request upgrade (using gui, not text, I am)
2. before upgrade starts I get the crash
3.
  
Actual results:
Text of crash written to floppy, first part is:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 951, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 146, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 217, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 273, in upgradeMountFilesystems
    allowDirty = 0)
  File "/usr/lib/anaconda/upgrade.py", line 147, in mountRootPartition
    oldfsset.mountFilesystems(instPath, readOnly = readOnly)
  File "/usr/lib/anaconda/fsset.py", line 1637, in mountFilesystems
    entry.mount(instPath, readOnly = readOnly)
  File "/usr/lib/anaconda/fsset.py", line 1840, in mount
    BindMountDevice))
  File "/usr/lib/anaconda/fsset.py", line 1050, in mount
    raise SystemError (errNum, errMsg)
UnboundLocalError: local variable 'errNum' referenced before assignment

Local variables in innermost frame:
device: /dev/fd0
bindMount: False
readOnly: 0
self: <fsset.AutoFileSystem instance at 0xb7d73e6c>
mountpoint: /mnt/sysimage//media/floppy

Then computer reboots from hard disk, not upgraded.
No upgrade actions took place, apparently.
Full anaconda.txt attached.
Expected results:
upgrade would work.


Additional info:
Comment 1 David Anderson 2006-04-01 19:54:39 EST
Created attachment 127191 [details]
dump written to floppy on anaconda crash.
Comment 2 Chris Lumens 2006-04-03 15:05:32 EDT

*** This bug has been marked as a duplicate of 185853 ***

Note You need to log in before you can comment on or make changes to this bug.