This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 18764 - gcc-2.96 crashes on bad code.
gcc-2.96 crashes on bad code.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks: 18524
  Show dependency treegraph
 
Reported: 2000-10-09 22:13 EDT by Omnifarious
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-27 10:09:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
This is the preprocessor output that causes the coredump. (311.24 KB, application/octet-stream)
2000-10-09 22:15 EDT, Omnifarious
no flags Details

  None (edit)
Description Omnifarious 2000-10-09 22:13:12 EDT
Compiling a certain file with errors causes a compiler crash.  I will try
to attach the preprocessor output I saved with --save-temps.

g++ -v --save-temps -pipe -march=i686 -g -I../include tests/testvisitor.cxx
-L../generated/lib
g++: Warning: -pipe ignored since -save-temps specified
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.0)
/usr/lib/gcc-lib/i386-redhat-linux/2.96/cpp0 -lang-c++ -D__GNUG__=2 -v
-I../include -D__GNUC__=2 -D__GNUC_MINOR__=96 -D__GNUC_PATCHLEVEL__=0
-D__ELF__ -Dunix -Dlinux -D__ELF__ -D__unix__ -D__linux__ -D__unix
-D__linux -Asystem(posix) -g -Acpu(i386) -Amachine(i386) -Di386 -D__i386
-D__i386__ -D__pentiumpro -D__pentiumpro__ -D__tune_pentiumpro__
tests/testvisitor.cxx testvisitor.ii
GNU CPP version 2.96 20000731 (Red Hat Linux 7.0) (cpplib)
(i386 Linux/ELF)
ignoring nonexistent directory "/usr/local/include"
ignoring nonexistent directory "/usr/i386-redhat-linux/include"
#include "..." search starts here:
#include <...> search starts here:
../include
/usr/include/g++-3
/usr/lib/gcc-lib/i386-redhat-linux/2.96/include
/usr/include
End of search list.
/usr/lib/gcc-lib/i386-redhat-linux/2.96/cc1plus testvisitor.ii -quiet
-dumpbase testvisitor.cxx -march=i686 -g -version -o testvisitor.s
GNU C++ version 2.96 20000731 (Red Hat Linux 7.0) (i386-redhat-linux)
compiled by GNU C version 2.96 20000731
(Red Hat Linux 7.0).
tests/testvisitor.cxx: In function `void iteratorTest (const StrChunkPtr
&)':
tests/testvisitor.cxx:44: variable `StrChunk::__iterator i' has initializer
but incomplete type
tests/testvisitor.cxx:44: invalid use of undefined type `class
StrChunk::__iterator'
../include/StrMod/StrChunk.h:65: forward declaration of `class
StrChunk::__iterator'
tests/testvisitor.cxx:45: variable `StrChunk::__iterator end' has
initializer but incomplete type
tests/testvisitor.cxx:45: invalid use of undefined type `class
StrChunk::__iterator'
../include/StrMod/StrChunk.h:65: forward declaration of `class
StrChunk::__iterator'
tests/testvisitor.cxx:48: Internal error #390.
tests/testvisitor.cxx:48: Internal compiler error in arg_assoc_type, at
../gcc/cp/decl2.c:4961
Please submit a full bug report.
See <URL:http://www.gnu.org/software/gcc/bugs.html> for instructions.

Compilation exited abnormally with code 1 at Thu Oct 5 10:31:19
Comment 1 Omnifarious 2000-10-09 22:15:14 EDT
Created attachment 3964 [details]
This is the preprocessor output that causes the coredump.
Comment 2 Jakub Jelinek 2000-10-27 10:09:13 EDT
Fix submitted to gcc-patches, if it is accepted, it will make it into
rawhide and upcoming gcc errata.
Comment 3 Jakub Jelinek 2000-11-13 04:12:47 EST
Fixed in gcc-c++-2.96-63 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.