Bug 18524 - g++ crashes on one invalid input and one valid one
Summary: g++ crashes on one invalid input and one valid one
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.0
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On: 18764 18765
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-06 13:47 UTC by Omnifarious
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-10 14:05:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Omnifarious 2000-10-06 13:47:56 UTC
g++ 2.96 has crashed on me twice now.  One time it crashed when I hadn't
put in the header that gave a definition for a class I was using.
The other time it crashed on some code that used the GNU named return value
optimization, which is non-standard, but supposedly supported by g++.

gcc GNATS tracking numbers: c++/611  c++/613

The compiler should not crash.

I entered these bugs into the GNATS system for gcc, and I recieved an
eventual message on gcc-announce claiming the gcc-2.96 was considered to be
a pre-release version, and while C, and FORTRAN were likely to still work,
the C++ compiler probably had a number of issues.
I understand some eagerness to put in new versions of things.  Especially
since the new gcc seems to have much better per-processor optimizations for
the x86 family of chips (including AMDs offerings), but I expect releases
to be stable.  That is, after all, a big part of what I pay RedHat for.  If
didn't care about stability, I'd download and compile the latest and
greatest for myself.
I find the instability of the gcc-2.96 C++ frontend to be disturbing.
I think a reasonable fix would be to provide a set of back-patches to move
gcc back to 2.95.2, and patches to the distributed programs that use C++ so
that they are binary compatible with gcc 2.95.2.

Comment 1 Omnifarious 2000-10-10 02:29:19 UTC
Duplicated the GNATS entries I made into the Bugzilla system as per the e-mail
send out on gcc-announce.


Comment 2 Jakub Jelinek 2000-10-20 16:07:18 UTC
I'll work on fixing #18764 and #18765, so I'm closing this one.


Note You need to log in before you can comment on or make changes to this bug.