Bug 187653 - hibernate kills network
hibernate kills network
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-02 07:08 EDT by drago01
Modified: 2015-01-04 17:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-12 00:50:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drago01 2006-04-02 07:08:56 EDT
Description of problem:
When I suspend my box (hibernate) and resume my network stops working.
Ip is configured as static.
even service network restart don't brings it back.
I have to reboot to have working network (and internet).


Version-Release number of selected component (if applicable):
2.6.16-1.2080_FC5

How reproducible:
always

Steps to Reproduce:
1. hibernate
2. resume
3. notice that network is broken and can only be actiated by reboot
  
Actual results:
no network after resume

Expected results:
network should work after resume


Additional info:

nic is using the forcedeth driver.
lspci output:
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev a2)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev a3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
01:09.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller
(rev 80)
01:0a.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit
Ethernet Controller (rev 13)
01:0b.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)
01:0b.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 0a)
05:00.0 VGA compatible controller: nVidia Corporation GeForce 7800 GTX (rev a1)
Comment 1 drago01 2006-04-08 03:39:21 EDT
same happens when I suspend to ram.
modprobe -r eth0
modprobe eth0
ifup eth0
also don't work.
why is the nic dead till next reboot?
Comment 2 drago01 2006-04-19 10:43:43 EDT
just wanted to note that I reported it upstream and it seems that the forcedeth
driver does not support suspend.
an experimental patch is also in the upstream bug:
http://bugzilla.kernel.org/show_bug.cgi?id=6398 (not tested yet)
Comment 3 drago01 2006-04-22 01:56:12 EDT
the patch in the upstream bugzilla fixes the problem for me.
can we have this simple patch (66 lines) into the FC5 kernel?
Comment 4 Jon Masters 2006-04-22 02:04:49 EDT
Patch looks ok and it only touches forcedeth too.
Comment 5 drago01 2006-04-24 11:24:27 EDT
dave any comments?
Comment 6 Dave Jones 2006-10-16 15:44:13 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 7 drago01 2006-10-18 14:38:20 EDT
No its still not fixed, but a patch exists see upstream bugreport for more details.
Comment 8 Dave Jones 2006-11-05 15:56:41 EST
patch merged for next update.
Comment 9 Dave Jones 2006-11-12 00:50:38 EST
should be fixed in 2.6.18-1.2239.fc5 now in updates.
Comment 10 drago01 2006-11-14 15:09:42 EST
2.6.18-1.2849.fc6 works fine thx for include the fix ( I don't have a fc5 box to
test it but its the same fix which worked before and works now in fc6 so I
assume that this is fixed too)

Note You need to log in before you can comment on or make changes to this bug.