Bug 1876797 - The "Last Updated" status of Installed Operators is not displayed correctly in OCP 4.5.
Summary: The "Last Updated" status of Installed Operators is not displayed correctly i...
Keywords:
Status: CLOSED DUPLICATE of bug 1910401
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.7.0
Assignee: Evan Cordell
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-08 08:10 UTC by Asheth
Modified: 2021-02-01 16:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-02-01 16:00:37 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Asheth 2020-09-08 08:10:51 UTC
Description of problem:
The "Last Updated" status of Installed Operators is not displayed correctly in OCP 4.5.

Version-Release number of selected component (if applicable):
OCP 4.5

How reproducible:
1. Install two operators for example ElasticSearch operator and Red Hat OpenShift Jaeger operators. While installing these Operators, specify the installation mode as "All Namespaces on the cluster".

2. View the "Last Updated" status of these operators. when selected "All Projects", it should display the "Last Updated" time properly. However, when  selected a particular namespace for example "kube-system or the other namespace, it displays incorrect "Last Updated" time.


Steps to Reproduce:
1. Log in to OpenShift Web-Console.

2. Install two operators for example ElasticSearch operator and Red Hat OpenShift Jaeger operators. While installing these Operators, specify the installation mode as "All Namespaces on the cluster".

3. View the "Last Updated" status of these operators. when selected "All Projects", it should display the "Last Updated" time properly. However, when  selected a particular namespace for example "kube-system or the other namespace, it displays incorrect "Last Updated" time.


Actual results:

The "Last Updated" time shows different/incorrect value when viewed from a particular namespace as compared to when viewed from the "All Namespaces".


Expected results:
The "Last Updated" time should show the same output/value when viewed from a particular namespace as compared to when viewed from the "All Namespaces".


Additional info:

Comment 7 Harish Govindarajulu 2020-10-30 14:51:44 UTC
When an operator is installed in all namespaces, the "source" CSV is created in openshift-operators namespace and the CSV is cloned in all other namespaces. The lastUpdateTime status field on the "cloned" CSVs is not updated whenever the source CSV changes in an inconsequential way and hence they have different values. I confirmed with Kevin and Nick from OLM team and they don't want to change this behavior. Hence closing this as won't fix

Comment 8 Harish Govindarajulu 2020-10-30 22:04:15 UTC
Discussed further with Nick from the OLM team and decided that it would be fixed on the OLM side

Comment 9 Asheth 2020-11-19 13:14:05 UTC
We are having the same issue in OCP 4.6. Can we fix it for 4.6 as well?

Comment 10 Kevin Rizza 2021-02-01 16:00:37 UTC
For an unrelated performance reason, this bug was resolved in https://bugzilla.redhat.com/show_bug.cgi?id=1910401. Marking this as a duplicate and closing.

*** This bug has been marked as a duplicate of bug 1910401 ***


Note You need to log in before you can comment on or make changes to this bug.