Bug 1876830 - Disable grafana telemetry.
Summary: Disable grafana telemetry.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.6.0
Assignee: Pawel Krupa
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks: 1877256
TreeView+ depends on / blocked
 
Reported: 2020-09-08 09:48 UTC by German Parente
Modified: 2021-07-22 09:11 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1877256 (view as bug list)
Environment:
Last Closed: 2020-10-27 16:38:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 834 0 None closed Disable grafana telemetry 2020-11-02 08:52:09 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 16:38:47 UTC

Description German Parente 2020-09-08 09:48:02 UTC
Description of problem:

we need to disable grafana telemetry in downstream as shown in this issue/pullrequest:

grafana pod outbound network connections
https://github.com/openshift/cluster-monitoring-operator/issues/828

Disable grafana telemetry
https://github.com/openshift/cluster-monitoring-operator/pull/834

That is to say, set

reporting_enabled = false 

in grafana.ini


Version-Release number of selected component (if applicable): 4.5


How reproducible: always


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 10 Junqi Zhao 2020-09-09 13:25:05 UTC
tested with 4.6.0-0.nightly-2020-09-08-123737, issue is fixed on 4.6
# oc -n openshift-monitoring exec -c grafana $(oc -n openshift-monitoring get po | grep grafana | awk '{print $1}') -- cat /etc/grafana/grafana.ini | grep reporting_enabled
reporting_enabled = false

Comment 13 errata-xmlrpc 2020-10-27 16:38:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.