Bug 1877256 - Disable grafana telemetry.
Summary: Disable grafana telemetry.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.5.z
Assignee: Damien Grisonnet
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 1876830
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-09 08:21 UTC by Simon Pasquier
Modified: 2020-09-21 17:42 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1876830
Environment:
Last Closed: 2020-09-21 17:42:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 922 None closed Bug 1877256: disable grafana telemetry 2020-09-21 17:44:25 UTC
Red Hat Product Errata RHBA-2020:3719 None None None 2020-09-21 17:42:23 UTC

Description Simon Pasquier 2020-09-09 08:21:49 UTC
+++ This bug was initially created as a clone of Bug #1876830 +++

Description of problem:

we need to disable grafana telemetry in downstream as shown in this issue/pullrequest:

grafana pod outbound network connections
https://github.com/openshift/cluster-monitoring-operator/issues/828

Disable grafana telemetry
https://github.com/openshift/cluster-monitoring-operator/pull/834

That is to say, set

reporting_enabled = false 

in grafana.ini


Version-Release number of selected component (if applicable): 4.5


How reproducible: always


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Pawel Krupa on 2020-09-08 10:03:54 UTC ---

This is already done in 4.6

--- Additional comment from Lili Cosic on 2020-09-08 10:08:10 UTC ---

So you want this backported to 4.5? Can you clarify a bit more why and how urgent this is. Thanks!

--- Additional comment from German Parente on 2020-09-08 10:16:25 UTC ---

Hi,

thanks a lot for checking this. I have never said this is urgent but in customer site this url is disabled: "stats.grafana.org". So, the customer is having errors all the time in the logs:

========
The grafana pod of project openshift-monitoring is trying to access 35.241.23.245 every 10 mins. This is not allowed and triggers firewall warnings.
Please disable!
========

--- Additional comment from Lili Cosic on 2020-09-08 10:23:14 UTC ---

Thanks for more info, we will backport the fix.

--- Additional comment from Eric Paris on 2020-09-08 12:00:56 UTC ---

This bug sets Target Release equal to a z-stream but has no bug in the 'Depends On' field. As such this is not a valid bug state and the target release is being unset.

Any bug targeting 4.1.z must have a bug targeting 4.2 in 'Depends On.'
Similarly, any bug targeting 4.2.z must have a bug with Target Release of 4.3 in 'Depends On.'

--- Additional comment from Simon Pasquier on 2020-09-09 08:20:15 UTC ---

Already fixed in 4.6 by https://github.com/openshift/cluster-monitoring-operator/pull/834.

Comment 2 Junqi Zhao 2020-09-14 01:42:36 UTC
tested with 4.5.0-0.nightly-2020-09-12-063044, issue is fixed on 4.5
# oc -n openshift-monitoring exec -c grafana $(oc -n openshift-monitoring get po | grep grafana | awk '{print $1}') -- cat /etc/grafana/grafana.ini | grep reporting_enabled
reporting_enabled = false

Comment 5 errata-xmlrpc 2020-09-21 17:42:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:3719


Note You need to log in before you can comment on or make changes to this bug.