Bug 1877000 - dnf cannot install python2 due to missing metadata
Summary: dnf cannot install python2 due to missing metadata
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: python2
Version: CentOS Stream
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 8.0
Assignee: Brian Stinson
QA Contact: RHEL CS Apps Subsystem QE
URL:
Whiteboard:
: 1877774 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-08 16:56 UTC by cparg
Modified: 2020-09-21 21:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-21 21:51:07 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description cparg 2020-09-08 16:56:42 UTC
Description of problem:
Cannot install python2 due to missing metadata

Version-Release number of selected component (if applicable):
I am using CentOS Stream with the following repositories:
repo id                                                     repo name
Stream-AppStream                                            CentOS-Stream - AppStream
Stream-BaseOS                                               CentOS-Stream - Base
Stream-PowerTools                                           CentOS-Stream - PowerTools
Stream-extras                                               CentOS-Stream - Extras
elrepo-kernel                                               ELRepo.org Community Enterprise Linux Kernel Repository - el8
epel                                                        Extra Packages for Enterprise Linux 8 - x86_64
packages.microsoft.com_yumrepos_ms-teams                    created by dnf config-manager from https://packages.microsoft.com/yumrepos/ms-teams
rpmfusion-free-updates                                      RPM Fusion for EL 8 - Free - Updates
rpmfusion-nonfree-updates                                   RPM Fusion for EL 8 - Nonfree - Updates
rpmfusion-nonfree-updates-testing                           RPM Fusion for EL 8 - Nonfree - Test Updates



Steps to Reproduce:
1. dnf install python2   or:
2. dnf install gimp


Actual results:
root@crusty : /home/cparg $ dnf install python2                                                                                                                    
Last metadata expiration check: 3:25:44 ago on Tue Sep  8 15:28:48 2020.                                                                                           
Dependencies resolved.                                                                                                                                             
===================================================================================================================================================================
 Package                                   Architecture            Version                                                 Repository                         Size
===================================================================================================================================================================
Installing:
 python2                                   x86_64                  2.7.17-2.module_el8.3.0+478+7570e00c                    Stream-AppStream                  109 k
Installing dependencies:
 python2-libs                              x86_64                  2.7.17-2.module_el8.3.0+478+7570e00c                    Stream-AppStream                  6.0 M
 python2-pip-wheel                         noarch                  9.0.3-18.module_el8.3.0+478+7570e00c                    Stream-AppStream                  1.0 M
 python2-setuptools-wheel                  noarch                  39.0.1-12.module_el8.3.0+478+7570e00c                   Stream-AppStream                  287 k
Installing weak dependencies:
 python2-pip                               noarch                  9.0.3-18.module_el8.3.0+478+7570e00c                    Stream-AppStream                  1.7 M
 python2-setuptools                        noarch                  39.2.0-6.el8                                            Stream-AppStream                  640 k

Transaction Summary
===================================================================================================================================================================
Install  6 Packages

Total size: 9.7 M
Installed size: 37 M
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] python2-2.7.17-2.module_el8.3.0+478+7570e00c.x86_64.rpm: Already downloaded                                                                             
[SKIPPED] python2-libs-2.7.17-2.module_el8.3.0+478+7570e00c.x86_64.rpm: Already downloaded                                                                        
[SKIPPED] python2-pip-9.0.3-18.module_el8.3.0+478+7570e00c.noarch.rpm: Already downloaded                                                                         
[SKIPPED] python2-pip-wheel-9.0.3-18.module_el8.3.0+478+7570e00c.noarch.rpm: Already downloaded                                                                   
[SKIPPED] python2-setuptools-39.2.0-6.el8.noarch.rpm: Already downloaded                                                                                          
[SKIPPED] python2-setuptools-wheel-39.0.1-12.module_el8.3.0+478+7570e00c.noarch.rpm: Already downloaded                                                           
Running transaction check
No available modular metadata for modular package 'python2-2.7.17-2.module_el8.3.0+478+7570e00c.x86_64', it cannot be installed on the system
No available modular metadata for modular package 'python2-libs-2.7.17-2.module_el8.3.0+478+7570e00c.x86_64', it cannot be installed on the system
No available modular metadata for modular package 'python2-pip-9.0.3-18.module_el8.3.0+478+7570e00c.noarch', it cannot be installed on the system
No available modular metadata for modular package 'python2-pip-wheel-9.0.3-18.module_el8.3.0+478+7570e00c.noarch', it cannot be installed on the system
No available modular metadata for modular package 'python2-setuptools-wheel-39.0.1-12.module_el8.3.0+478+7570e00c.noarch', it cannot be installed on the system
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: No available modular metadata for modular package



Expected results:
I would like to use python2 and gimp but this issue is blocking both.

Additional info:
dnf clean packages does not help

Comment 1 Miro Hrončok 2020-09-10 12:40:19 UTC
*** Bug 1877774 has been marked as a duplicate of this bug. ***

Comment 2 cparg 2020-09-14 09:51:50 UTC
I did increase severity to urgent as it is really blocking work for me.

Comment 3 kangshan0910@hotmail.com 2020-09-15 07:22:17 UTC
Here is a workaround, add “AppStream” “BaseOS” and “extras” repos from CentOS8.
dnf config-manager --enable AppStream
dnf config-manager --enable BaseOS
dnf config-manager --enable extras

Comment 4 cparg 2020-09-15 13:39:05 UTC
Thanks a lot for the workaround. It works!

It is not clear to me whether the CentOS-8 repositories are in conflict with the CentOS-Stream repositories or not.

Comment 5 Brian Stinson 2020-09-21 21:51:07 UTC
This should be resolved with the update that is going out to the mirrors right now. Once your closest mirror is up to date, you should be able to install python27 content like normal.


Note You need to log in before you can comment on or make changes to this bug.