Bug 1877774 - No available modular metadata for modular package
Summary: No available modular metadata for modular package
Keywords:
Status: CLOSED DUPLICATE of bug 1877000
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: python2
Version: CentOS Stream
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Python Maintainers
QA Contact: RHEL CS Apps Subsystem QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-09-10 12:19 UTC by Jakub Kadlčík
Modified: 2020-09-10 12:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-10 12:40:19 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Jakub Kadlčík 2020-09-10 12:19:29 UTC
Description of problem:
I am not able to install python2 on centos-stream because of "No available modular metadata for modular package" error.


How reproducible:
Always

Personally I am running Fedora as my host system and reproduce this by using Mock. This is the way we discovered this issue in Copr. The reproducer will probably be even simpler when running Centos Stream system.


Steps to Reproduce:
1. mock -r centos-stream-x86_64 --install python2


Actual results:

Total download size: 9.7 M
Installed size: 37 M
Downloading Packages:
(1/6): python2-2.7.17-2.module_el8.3.0+478+7570e00c.x86_64.rpm                                                                                                                                                 269 kB/s | 109 kB     00:00    
(2/6): python2-pip-wheel-9.0.3-18.module_el8.3.0+478+7570e00c.noarch.rpm                                                                                                                                       772 kB/s | 1.0 MB     00:01    
(3/6): python2-setuptools-39.2.0-6.el8.noarch.rpm                                                                                                                                                              842 kB/s | 640 kB     00:00    
(4/6): python2-pip-9.0.3-18.module_el8.3.0+478+7570e00c.noarch.rpm                                                                                                                                             633 kB/s | 1.7 MB     00:02    
(5/6): python2-setuptools-wheel-39.0.1-12.module_el8.3.0+478+7570e00c.noarch.rpm                                                                                                                               919 kB/s | 287 kB     00:00    
(6/6): python2-libs-2.7.17-2.module_el8.3.0+478+7570e00c.x86_64.rpm                                                                                                                                            886 kB/s | 6.0 MB     00:06    
-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                                          1.4 MB/s | 9.7 MB     00:06     
Running transaction check
No available modular metadata for modular package 'python2-2.7.17-2.module_el8.3.0+478+7570e00c.x86_64', it cannot be installed on the system
No available modular metadata for modular package 'python2-libs-2.7.17-2.module_el8.3.0+478+7570e00c.x86_64', it cannot be installed on the system
No available modular metadata for modular package 'python2-pip-9.0.3-18.module_el8.3.0+478+7570e00c.noarch', it cannot be installed on the system
No available modular metadata for modular package 'python2-pip-wheel-9.0.3-18.module_el8.3.0+478+7570e00c.noarch', it cannot be installed on the system
No available modular metadata for modular package 'python2-setuptools-wheel-39.0.1-12.module_el8.3.0+478+7570e00c.noarch', it cannot be installed on the system



Expected results:

All packages should be installed sucessfully.

Comment 1 Miro Hrončok 2020-09-10 12:40:19 UTC

*** This bug has been marked as a duplicate of bug 1877000 ***


Note You need to log in before you can comment on or make changes to this bug.